[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian 3.1 and HP LaserJet 4P



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

albert.chang@comcast.net writes:

> I have debian 3.1, and not quite new to the linux community.  I have
> an HP LaserJet 4P printer hooked up to the computer through a serial
> port.  It has worked with Fedora Core 4 Linux, Windows NT, Windows
> 2000, and Windows XP all with the same cable.  Debian-based Linux,
> such as Debian and Ubuntu, are the only operating systems having
> trouble with my printer.

OK.  The LaserJet 4x series of printers are well supported, so it
shouldn't be too hard to set it up.  You need to install these
packages:

cupsys
cupsys-client
gs-esp
foomatic-filters
foomatic-db-hpijs
foomatic-filters-ppds
hpijs

If you recompiled anything yourself (the forum messages indicated this
might be the case), I suggest running

# apt-get --reinstall install cupsys cupsys-client gs-esp \
  foomatic-filters foomatic-db-hpijs foomatic-filters-ppds hpijs libcupsimage2 libcupsys2

Next, restart CUPS:

# /etc/init.d/cupsys restart

Now CUPS should be ready to configure.  Point your web browser to
http://localhost:631/ and choose "Add Printer".  Choose "HP LaserJet
4P Foomatic/hpijs (recommended)".  Now try to print a test page.  What
happens?

As an alternative, install cupsys-driver-gimpprint, and choose "HP
LaserJet 4 series - CUPS+Gimp-Print v4.2.7".  This might give better
dithering of grayscale and colour images.


Regards,
Roger

- -- 
Roger Leigh
                Printing on GNU/Linux?  http://gimp-print.sourceforge.net/
                Debian GNU/Linux        http://www.debian.org/
                GPG Public Key: 0x25BFB848.  Please sign and encrypt your mail.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Processed by Mailcrypt 3.5.8+ <http://mailcrypt.sourceforge.net/>

iD8DBQFDNUcXVcFcaSW/uEgRAidnAJ9+J6I+j515IyEU/lmPKSHYksKiagCgteKs
QagqDmGsMrK2w0VsaOfTJt8=
=GjcH
-----END PGP SIGNATURE-----



Reply to: