[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Updated installation images for Debian Ports 2019-11-22

On 11/24/19 4:06 PM, John Paul Adrian Glaubitz wrote:

On Nov 24, 2019, at 4:20 PM, roberto.guardato <roberto.guardato@gmail.com> wrote:

Hi Adrian,
i've tested the image for ppc64 on powermac G5, it has the same problem installing the bootloader.

Yes, as I have communicated here already I have not worked on this issue yet due to lack of time.

But so far people keep insisting using Yaboot which is unmaintained and buggy instead of willing to work on ofpathname. So the ofpathname issue won’t be worked on until I have time for it.

I don’t mean to be snarky, I’m just explaining the current situation and why the issue isn’t yet fixed.

Yaboot isn’t an option. It’s no longer maintained, has build dependencies on libraries no longer maintained either and removed from Debian and also doesn’t support modern ext4 filesystem features.

So, unless Yaboot gets a new upstream maintainer to fix all these issues, it’s not an option.

Also, for anyone with a Mac, I have left the Yaboot images in the “10.0” folder.


I appreciate the work that you do and wonder if I can help a bit here.

The issue seems to be that the open firmware data is being
misrepresented or misunderstood to the grub boot loader or is there
a nice bug report somewhere I can look at ?

Dennis Clarke
UNIX and Linux spoken
GreyBeard and suspenders optional

Reply to: