[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can not run installer with new GRUB image

Sent from ProtonMail Mobile

On Mon, May 27, 2019 at 11:21 AM, unilock <haydena9448@gmail.com> wrote:
> I tried the new image "debian-10.0-powerpc-grub-NETINST-1.iso" from [1] on a PowerMac11,2 (Power Mac G5).
> I was able to boot the cd with GRUB, but I was not able to run the installer.
> ...
> I see grub and I can select "default install", but after that I end up with a blank screen from Open Firmware telling me "Invalid memory access".

I'm running into a similar issue on my PowerMac8,2 (iMac G5).
I've tested both "debian-10.0-powerpc-grub-NETINST-1.iso" and "debian-10.0-powerpc-grub-new-NETINST-1.iso", burned to CD-R's.
With both CDs, after selecting "Default install" in GRUB, I eventually arrive at OpenFirmware informing me of an "Invalid memory access".

I've uploaded a picture of the phenomenon here: https://i.imgur.com/iYI7KDO.jpg

Note that my iMac has two 1GB DIMMs installed, totaling 2GB of RAM.
However, I've encountered the same error when running the installer after removing one DIMM (leaving only a single 1GB DIMM installed).

That error usually occurs when running the 32-bit installer on a 64-bit machine. With yaboot, it was possible to select “install64” and proceed with the install. I haven’t attempted to install with the newer images, so I can’t advise on how to start the 64-bit install. Maybe there’s a 64-bit installer iso on the site? I’m sure someone else here could help.


Reply to: