[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Can not run installer with new GRUB image

I tried the new image "debian-10.0-powerpc-grub-NETINST-1.iso" from [1]
on a PowerMac11,2 (Power Mac G5).

I was able to boot the cd with GRUB, but I was not able to run the

To boot the image, I dd'ed it on a USB drive and booted with
OpenFirmware by using the following commands:

boot ud:,\boot\grub\powepc.elf
boot ud:,\\:tbxi
boot ud:,\System\Library\CoreServices\grub.elf

I see grub and I can select "default install", but after that I end up
with a blank screen from Open Firmware telling me "Invalid memory access".

MD5SUM from my USB stick is the same as the downloaded is, as to say:

I also tried to boot the same USB drive on a PowerMac6,4 (eMac G4), but
I was not able to list the files contained in the file system.

I used the command:

dir /pcif2000000/usb@1b/disk@1:,\

which returned me "can't OPEN the DIR device".

If someone can see an error in this last OF line, please let me know.


[1] https://cdimage.debian.org/cdimage/ports/grub-test/

Reply to: