[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can not run installer with new GRUB image

On 5/6/19 6:30 PM, aggaz wrote:
> I tried the new image "debian-10.0-powerpc-grub-NETINST-1.iso" from [1]
> on a PowerMac11,2 (Power Mac G5).
> I was able to boot the cd with GRUB, but I was not able to run the
> installer.
> To boot the image, I dd'ed it on a USB drive and booted with
> OpenFirmware by using the following commands:
> boot ud:,\boot\grub\powepc.elf
> boot ud:,\\:tbxi
> boot ud:,\System\Library\CoreServices\grub.elf
> I see grub and I can select "default install", but after that I end up
> with a blank screen from Open Firmware telling me "Invalid memory access".

This sounds like a compatibility issue with GRUB or the kernel on your
particular machine. I don't think it's related to the bootability of
image itself.

> MD5SUM from my USB stick is the same as the downloaded is, as to say:
> 433d57104eaca06cd450d87f7f63e368
> I also tried to boot the same USB drive on a PowerMac6,4 (eMac G4), but
> I was not able to list the files contained in the file system.
> I used the command:
> dir /pcif2000000/usb@1b/disk@1:,\
> which returned me "can't OPEN the DIR device".
> If someone can see an error in this last OF line, please let me know.

Does the machine boot with the image burned to a CD?


 .''`.  John Paul Adrian Glaubitz
: :' :  Debian Developer - glaubitz@debian.org
`. `'   Freie Universitaet Berlin - glaubitz@physik.fu-berlin.de
  `-    GPG: 62FF 8A75 84E0 2956 9546  0006 7426 3B37 F5B5 F913

Reply to: