[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Trying 2019-04-11 on PowerMac G4 Silver - [Solved]

On 4/14/19 20:28, Rick Thomas wrote:
On Apr 13, 2019, at 5:39 AM, Frank Scheiner <frank.scheiner@web.de> wrote:

Do you happen to have a smaller disk (e.g. below 128 GB) available for
use? Or maybe you try with a separate small (512 MiB or so) `/boot`
partition directly after the HFS bootstrap partition, so the kernel is
located in the first GiB of this disk.

Thanks, Frank!  That was the clue it needed.

I used the 2019-04-12 iso for my most recent test, just incase there was a change that might affect the problem.

I did everything the same as I did for the original test, except that when it got to partitioning the disk, I chose guided partitioning and “Use whole disk, with LVM”.  The LVM part forces it to create a separate /boot partition directly after the HFS one.

That installed GRUB, which booted without a hitch.

Cool, that it worked out for you. :-) Maybe something for the Debian
wiki. We already have a machine specific part for sparc64 on [1] and
something similar for powerpc/ppc64 could be useful for new users. I
could test through my collection of B&W G3 and G4s to gather additional
info. I expect later G4s won't have such a limitation.

[1]: https://wiki.debian.org/Sparc64#Known_Working_System_Configurations

So it appears that this model of PowerMac has boot firmware that doesn’t like the high-address parts of large disk drives.  Interestingly enough, this problem does not seem to affect the Linux kernel.  Once past the bootstrap firmware, it works fine with the 300GB disk.

I assume this is due to Linux using its own drivers to access the ATA
controller and disk. And therefore it really must be a firmware
limitation, because with a hardware limitation also Linux wouldn't work
properly IIC.

Thanks to all!

You're welcome.


Reply to: