[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#853755: installation-reports: ppc64el fails to boot after installation

Am 02.02.2017 um 15:56 schrieb Erwan Prioul:
> On 02/02/2017 02:46 PM, Michael Biebl wrote:
>> Erwan, could you try 232-1 from snapshots.debian.org and see if the
>> problem is reproducible there?
> I ran few tests.
> 232-1 is OK, same result for 232-8 and 232-10.
> The issue appeared in 232-11.

Let me quote what I wrote in #853940

> The sandboxing features (based on seccomp) are available in systemd
> since a while, but were not actively used in .service units.
> In 232-1 for a couple of systemd services, like logind, udevd or
> journald those were turned on.
> This caused problems on i386, so we temporarily removed them from the
> .service files. seccomp support was reworked upstream and we backported
> those patches in 232-11 and reenabled the sandboxing features.
> I guess it would be worthwile testing 232-1 from snapshot.d.o [1]
> This would show if seccomp support has been broken in previous releases
> as well, or if the backported patches [2] from 232-11 caused a
> regression on powerpc.
> Michael
> [1] http://snapshot.debian.org/
> [2]
> https://anonscm.debian.org/cgit/pkg-systemd/systemd.git/commit/?id=c31b5ee9b9c79c9d2ac491920b23a8084a4ccc46

The relevant upstream bug report is

That seccomp code is admittedly over my head. I guess it would be best
if you take this issue upstream and talk directly to them, letting them
know that the changes from #4575 apparently caused a regression on powerpc.

As for the stretch release, I'm currently undecided what the best course
of action is. Disabling the sandboxing features/Seccomp on ppc* seems
like an option.

Adrian said he wanted to look into this over the weekend. So maybe we
know more then.


Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: