[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#853755: installation-reports: ppc64el fails to boot after installation

Am 02.02.2017 um 14:22 schrieb Cyril Brulebois:
> Hi Erwan,
> Erwan Prioul <erwan@linux.vnet.ibm.com> (2017-02-02):
>> AFAIK 4.9.6-x is not yet provided in the daily image for ppc64el.
>> It's still the 4.9.2-2. Anyway, I ran a couple of tests with
>> 4.9.6-3 and 4.8.15-2, and I got the same error.
> The switch from 4.9.2 to 4.9.6 was first seen with d-i daily builds
> with this one:
>   https://d-i.debian.org/daily-images/ppc64el/20170130-00:02/
>> I did another install but this time I took the previous version of
>> systemd, 232-8 instead of 232-14 (current version), and it worked.
> Ah, right, that's one of the big differences between a boot to d-i and
> a boot to the installed system… Good catch!
>> I'll reassign this to systemd.
> An easy suspect would be:
> | commit 7b17f7c824429e95826528d4c6e9d40662ae45ca
> | Author: Michael Biebl <biebl@debian.org>
> | Date:   Wed Jan 18 19:43:28 2017 +0100
> | 
> |     Enable seccomp support on ppc64

ppc64 != ppc64el, or am I missing something?

seccomp support has been enabled on ppc64el since almost a year:


Do we have any ppc/powerpc porters which can help us in that regard and
let us know if seccomp is working on that architecture:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=853755 (ppc64el)
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=853940 (powerpc)
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=852811 (ppc64)

Could it be that older versions were already broken but it simply went
unnoticed because none of the sandboxing features were used in the
.service files?

Erwan, could you try 232-1 from snapshots.debian.org and see if the
problem is reproducible there?

Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: