[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installation: xserve G4 with broken CD drive

Hello all,

I'm trying to get squeeze up and running on an xserve G4 with a broken CD drive.  It doesn't seem to want to boot from an
extrnal firewire CD, but will boot OSX from an iBook set in target mode.  Oddly, it won't boot from a CD in said iBook.

Things tried so far:
Put the Xserve in target mode, install wheezy onto it via debootstrap (plus a kernel), edited fstab and so on, ran ybin,
unmounted and rebooted.  It gots to yaboot stage 1 OK, but when I press 'l', a blue folder pops up in the middle
of the screen with the icon alternating between a question mark and the happymac logo.

Eventually I got the bright idea of reading the ybin man page, and realized that the iBook's Open Firmware path to the xserve's
ultra0 drive in while target mode is very different from the xserve's idea of its own drive when booting normally. It would
seem fair to say that ofpath is 'failing', thus the necesity of specifying it explicitly in the ybin command.  I figured out the
appropriate values by booting the xserve into open firmware, corrected yaboot.conf, and ran ybin with all options specified.
Same result.

Then I realized that in target mode, the xserve's drive is called /dev/sda by the ibook, but to itself when booting, it's
/dev/hda, so I dug into openfirmware yet again to grab the self-referred drive names, but with the same result.

Is my approach valid?  Have I made some not-so-obvious mistake in the config or ybin, or should I just give up and track down a
replacement CD drive?

Peter Rooney


# yaboot.conf used:




# ybin command used:
ybin -b /dev/sda2 --ofboot /pci@f200000000/AppleKiwi@15/ata-6@0/disk@0  --config /mnt/etc/yaboot.conf --nonvram -v

# partition layout of xserve (in target mode) as seen by iBook (debian squeeze):
        #                    type name                  length   base      ( size )  system
/dev/sda1     Apple_partition_map Apple                     63 @ 1         ( 31.5k)  Partition map
/dev/sda2         Apple_Bootstrap bootstrap               1600 @ 64        (800.0k)  NewWorld bootblock
/dev/sda3         Apple_UNIX_SVR2 theroot             52428800 @ 1664      ( 25.0G)  Linux native
/dev/sda4         Apple_UNIX_SVR2 swap                 8388608 @ 52430464  (  4.0G)  Linux swap
/dev/sda5         Apple_UNIX_SVR2 thehome             56412336 @ 60819072  ( 26.9G)  Linux native

Block size=512, Number of Blocks=117231408
DeviceType=0x0, DeviceId=0x0

Reply to: