[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Power Mac G5 & Radeon X1900 - driver problem

I was attempting to get Debian (Squeeze, latest net-install CD)
working with a Radeon X1900 Mac edition video card (PCI-Express) on my
Power Mac G5 Quad. The installer acted a bit weird right from the
start, telling me that the step "Install the system" failed (with
nothing in the way of useful error information,) but I got the base
system installed at least. It booted fine to framebuffer console, so I
set about installing GNOME on it. apt finished with nary a complaint,
but when I rebooted, I found that when it was ready to launch into X,
it choked up and just sat there with a blank screen and a cursor.
(Weirdly, though, the screen itself flickered on and off at a high
rate, faster than the actual cursor blink.)

Framebuffer console still worked, at least, so I was able to boot into
single-user mode and do some investigating in my own limited capacity
for this stuff (by which I mean "Google error messages and see what
specifics are requested.") lspci -k showed the video card properly
with the manufacturer and product name, so it was recognizing it, at
least. When I tried Xorg -configure, though (Xorg 1.7.7, it says,) it
aborted with a "No DRICreatePCIBusID symbol" message. Checking dmesg
gave me a "process Xorg mapped non-existing PCI legacy memory"
message, followed by an "invalid ROM contents" message underneath.

For the time being, I put the GeForce 6600 it came with back in and
got things up and running. However, when I updated to Sid (unstable)
to get Lightspark working, I thought I'd give it another try and see
what happened. The flickering-cursor screen now does not happen, it
recognizes the card fully and attempts to load the radeon driver -
however, it's apparently conflicting with something or other:

conflicting fb usage radeondrmfb vs OFfb ATY,Priona - removing generic

This causes the system to hang completely, such that it can't even
boot into single-user mode...any changes made to fix it will need to
be done with the GeForce in its place.

I'm not sure what all to make of this. I've found a thread about
problems getting the same basic setup (G5 Quad, X1900, Debian) to
work, but it's a couple years old and the symptoms are different.
There's some discussion there about the radeon/radeonhd driver looking
for Atom BIOS information on non-Atom BIOS cards, which would explain
the "invalid ROM contents" message when running Squeeze, but on the
other hand, that seems to be fixed in Sid. Obviously it's playing
nicely enough to run framebuffer console output properly, but beyond
that I'm not so sure. Does that "conflicting fb usage" message
indicate some kind of driver conflict? If so, is there a way I can
disable whatever's conflicting with it and leave only the radeon
driver in place?

Reply to: