[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: fresh install of squeeze cannot compile alsa




I don't know what hardware you're using, but on my g3 ibook, I've always had to run the 'alsaconf' command and then 'alsactrl restore' and then the sound just magically worked. However, with the release of squeeze, alsaconf is missing. I don't know why:

http://www.google.com/search?q=alsaconf+squeeze&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:unofficial&client=iceweasel-a

What I did was to edit my /etc/sources.list to change all the lines back to lenny. I did an

apt-get remove alsa-utils alsa-base alsa-tools
apt-get update
apt-get clean
apt-get install alsa-utils alsa-base alsa-tools
alsaconf
alsactrl restore

and voila! working sound. I then put my /etc/sources.list back how I found it, did an apt-get update, and everything is running great.

I don't know if that will work on your hardware, and I'll be interested in entertaining suggestions that I broke something that I don't know about. But so far, so good.

Robert

On Thu, 19 May 2011, m laks wrote:

after all my trouble with sound before i decided to start from scratch

i decided to reinstall because i had trouble with sound.
so after fresh install of squeeze desktop and then add in mpg321 from debian-mulitmedia then still no sound using module-assistant to compile alsa modules and it failed

i changed to /usr/src/modules/alsa-driver/ and ran make

make -C /lib/modules/2.6.32-5-powerpc/build SUBDIRS=/usr/src/modules/alsa-driver  CPP="gcc-4.3 -E" CC="gcc-4.3" modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.32-5-powerpc'
 CC [M]  /usr/src/modules/alsa-driver/aoa/fabrics/layout.o
In file included from /usr/src/modules/alsa-driver/aoa/fabrics/layout.c:2:
/usr/src/modules/alsa-driver/aoa/fabrics/../../alsa-kernel/aoa/fabrics/layout.c: In function ‘check_codec’:
/usr/src/modules/alsa-driver/aoa/fabrics/../../alsa-kernel/aoa/fabrics/layout.c:772: error: ‘struct device_node’ has no member named ‘phandle’
make[6]: *** [/usr/src/modules/alsa-driver/aoa/fabrics/layout.o] Error 1
make[5]: *** [/usr/src/modules/alsa-driver/aoa/fabrics] Error 2
make[4]: *** [/usr/src/modules/alsa-driver/aoa] Error 2
make[3]: *** [_module_/usr/src/modules/alsa-driver] Error 2
make[2]: *** [sub-make] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.32-5-powerpc'
make: *** [compile] Error 2
root@natanya:/usr/src/modules/alsa-driver#


--
To UNSUBSCRIBE, email to debian-powerpc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 439198.73742.qm@web33406.mail.mud.yahoo.com">http://lists.debian.org/439198.73742.qm@web33406.mail.mud.yahoo.com

Reply to: