[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian won't boot after removal of video card

So I have Debian (Lenny) installed on a G4 Xserver cluster node (specs here).
We put 2 cards in the PCI riser expansion slot, a ATI Radeon 7000 and a 10/100 Nic.

Everything installed fine and was booting perfectly, we setup SSH tested it and it worked. So at this point we figured we could take the video card out as it was no longer needed since we could just ssh into the server. Upon removal of the video card and booting it up we found that it would no longer boot, it would hang very early in the boot process. We figured this out by turning on boot logging and found that it would not even create a boot log file for the times it didn't have a video card. So we are guessing that it is something with the boot loader (yaboot) and it hanging because it expects that video card to be in there. We tried editing our /etc/yaboot.conf file with several different boot arguments and updating it to the system with ybin. 

Were some of the ones we tried. This was honestly a bit of shooting in the dark because we were really not sure if it was the boot loader, but it was our best guess.

Anyway so has anyone come across this issue of PPC's not booting up properly after removal of a video card? It had us stumped for over 3 hours yesterday :(


Reply to: