[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing Debian Lenny on MacMini G4


The convention on Debian mailing lists is to post new information at the bottom. (It would not be my personal choice, but... "When in Rome, do as the Romans...")

I've re-arranged the parts of this as if that convention had been followed, then added my own comments at the end.


--- On Sun, 7/25/10, Mathieu Malaterre <mathieu.malaterre@gmail.com> wrote:

From: Mathieu Malaterre <mathieu.malaterre@gmail.com>
Subject: Installing Debian Lenny on MacMini G4
To: debian-powerpc@lists.debian.org
Date: Sunday, July 25, 2010, 4:46 PM

Hi there,

  I am trying to install Debian 5.0.5 on a used MacMini G4.
  I have followed instructions from:

However I could not get the MacMini to boot onto the debian installer.
  I tried the:
- 'C' holding approach (does not work at all)
- 'Options' holding approach (Only the hard drive icon shows up)
- 'Option'+'Command'+'o+'f' opens a terminal:

Apple PowerMac10, 1 4.8.9f4 BootROM build on 03/23/05 at 14:22:23
0 > boot cd:,\\tbxi DISK-LABEL: read block0 failed
ATAPI-DISK: open of DISK-LABEL failed can't open: cd:,\\tbxi
Can't open device or file
0 > eject cd: ok
0 > boot cd:,\\tbxi DISK-LABEL: read block0 failed
ATAPI-DISK: open of DISK-LABEL failed can't open: cd:,\\tbxi
Can't open device or file

I tried the 'eject' approach as mentioned in the bugzilla bug number 162046...

I have one cdrom burned from my debian/amd64 laptop and one cdrom
burned from the MacMini, both fails as shown above. Both cdrom opens
fine on my debian/amd64 laptop.


I would really appreciate *any* help !

Thanks in advance,

On Sun, Jul 25, 2010 at 7:10 PM, Chris Reich <chrisreich@rocketmail.com > wrote:

You say that both the CDs you are trying open fine on your amd64 laptop. It sounds like you may be trying to use an AMD/Intel architecture installation disk in a Power PC architecture computer. That won't work.

You'll need to download and burn the iso file of the Power PC architecture of Debian 5. Here is the url to the page from which you can download the DVD:


and here is the url from which you can download the CD:


You should be able to use the DVD on your Mac Mini.

I hope this helps you. Debian on old Macs rocks.

All my best - Chris Reich; Rochester, New York
twittername: chrisreich

On Sun, Jul 25, 2010 at 7:27 PM, Mathieu Malaterre
<mathieu.malaterre@gmail.com> wrote:

Hi Chris,

  As mentioned in my previous email I used:


  The cdrom opens fine on my laptop, dmesg reveals:

ISO 9660 Extensions: RRIP_1991A

I tried booting from them, but it simply fails. I am guessing they contains ppc code and thus fails on my amd64 laptop.


On Jul 25, 2010, at 2:11 PM, Mathieu Malaterre wrote:

BTW I actually meant to write:

boot cd:,\\:tbxi

This command does not work on my debian installation cd, but does work
on the official Tiger Mac install cd...

thanks !


If you tried both the "C" holding approach and the "Option" holding approach, and neither of them recognized that the CD is a bootable PowerPC Mac CD, then there must be something wrong with the CD. Either the iso is malformed, or the burn from the iso did not work properly.

To check the first possibility, did you verify the download by comparing the checksum of the iso file against either the MD5SUMS or the SHA1SUMS file in the same directory as you downloaded the iso from?

To check the second possibility, you can compare the burned CD with the iso file using, for example, something like:
	cmp /dev/cdrom xxxxxx.iso

A third possibilty, though remote, is that the iso was improperly built. I'll verify that myself and get back to you.

Have you tried booting the Mac mini G4 from another Debian CD? try, for example, the businesscard CD at
If that at least boots (it may fail to install a working Debian PowerPC for other reasons, but it should at least boot) then you know your CD drive is OK. If it fails, you may have a hardware problem...

Hope this helps!


Reply to: