[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Partition and Boot loader for Squeeze on G4

Rick Thomas wrote:
On Apr 26, 2010, at 7:10 AM, Shawn H Corey wrote:
PowerPCs always use yaboot.

Does yaboot know enough about LVMs and RAIDs to find the kernel and initrd in a root partition that's in a logical volume on a software raid-1?

I never used yaboot with RAID so I wouldn't know.

To be safe, I'd create a real, live, physical root (or at least a /boot -- not the same as the "Apple_Bootstrap") on each of physical disks of the RAID-1, and periodically mirror them from the "active one". Then if the disk with the active root (or /boot) goes south, you can manually tell yaboot to use one of the mirrors.

The Apple_Bootstrap is need so that OpenFirmware can find it and load yaboot. You do not need to mount it on Linux. As you can see below, on my machine, /dev/hda2 is the bootstrap but it is not mounted. The /boot directory would be on the Linux root partition.

$  sudo mac-fdisk -l
# type name length base ( size ) system /dev/hda1 Apple_partition_map Apple 63 @ 1 ( 31.5k) Partition map /dev/hda2 Apple_Bootstrap untitled 1954 @ 64 (977.0k) NewWorld bootblock /dev/hda3 Apple_UNIX_SVR2 untitled 5859376 @ 2018 ( 2.8G) Linux native /dev/hda4 Apple_UNIX_SVR2 swap 3013141 @ 75127019 ( 1.4G) Linux swap /dev/hda5 Apple_UNIX_SVR2 untitled 19531251 @ 5861394 ( 9.3G) Linux native /dev/hda6 Apple_UNIX_SVR2 untitled 49732422 @ 25392645 ( 23.7G) Linux native /dev/hda7 Apple_Free Extra 1952 @ 75125067 (976.0k) Free space

Block size=512, Number of Blocks=78140160
DeviceType=0x0, DeviceId=0x0

$  mount | column -t
/dev/hda3 on / type ext4 (rw,errors=remount-ro)
proc       on  /proc                     type  proc        (rw)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none       on  /sys/fs/fuse/connections  type  fusectl     (rw)
none       on  /sys/kernel/debug         type  debugfs     (rw)
none       on  /sys/kernel/security      type  securityfs  (rw)
udev       on  /dev                      type  tmpfs       (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none       on  /dev/shm                  type  tmpfs       (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755) none on /var/lock type tmpfs (rw,noexec,nosuid,nodev) none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/dev/hda5  on  /usr                      type  ext4        (rw)
/dev/hda6  on  /home                     type  ext4        (rw)

I've never actually tried that, myself. The configuration I use personally is slightly less reliable but much easier to set-up. I have 3 disks, one small one and two big ones. The two big ones are setup in a raid-1 and partitioned with LVM. All user data resides on the RAID/LVM. The small disk has everything necessary to boot the system, find the LVM and so on, but nothing that can't be reconstructed by re-installing -- i.e. no user data. If the root disk goes south, I can replace it and use a live-cd to restore it from backups or re-install it from scratch using an install CD.

Have you tried a Live USB yet? http://mac.linux.be/phpBB3/viewtopic.php?f=10&t=85

Just my 0.00000002 million dollars worth,

Programming is as much about organization and communication
as it is about coding.

I like Perl; it's the only language where you can bless your

Eliminate software piracy:  use only FLOSS.

Reply to: