[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ath9k problems

I searched the net a bit and couldn't come up with anything, so I am
assuming I'm about the only person using an ath9k-driven wireless card
on an older powerbook, or something like that...

I am running sid on a g4 powerbook dvi, using a d-link dwa-652 wireless
card. With the 2.6.29-2-powerpc kernel, the card works, mostly. The
connection is dropped quickly when there is no activity. If I keep ping
running in the background, the connection usually stays up. Stop ping,
and the connection is lost within seconds.

From what I gathered, recent changes in the ath9k driver may address
this issue, so I tried the 2.6.30-1-powerpc kernel.

The kernel upgrade to 2.6.30-1-powerpc completely breaks the driver.
dmesg says:

ath9k: 0001:11:00.0: enabling device (0000 -> 0002)
ath9k: 32-bit DMA not available
ath9k: probe of 0001:11:00.0 failed with error -5

And the Link LED just slowly turns on and off (on for one second, off
for one second, repeat -- I have no idea if this is at all relevant).

FWIW, I also tried compiling compat-wireless for 2.6.30 and it gives me
the same DMA and error -5 messages.

Any suggestions? Time to file a bug report? Would it be a debian bug or
a linux-wireless/kernel bug?


Reply to: