[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PowePC sid_d-i daily builds are not happening...

On Sun, 31 May 2009, Steve McIntyre wrote:
> On Sat, May 30, 2009 at 02:01:24PM -0400, Rick Thomas wrote:
> > On May 24, 2009, at 2:39 AM, Rick Thomas wrote:
> >
> >> http://cdimage.debian.org/cdimage/daily-builds/sid_d-i/arch-latest/powerpc/iso-cd/
> >>
> >> says that "This build finished at Mon May 18 22:27:07 UTC 2009."
> >>
> >> That's almost a week ago.  I'd like to test a new sid installation on 
> >> one of my Macs but until this is fixed, I can't.  Any idea when it will 
> >> be working again?
> >
> > This has not changed in the last week.  It still says May 18th, 2009.
> >
> > What is wrong and what can we do to fix it?
> Sorry, no idea what was wrong but just as I went to look at the logs
> of the last build the latest one just succeeded.

I gave the one from 2009-06-03 a try on PS3, and it's still missing some
required modules (ps3rom (CD/DVD/BD), ps3disk (HDD), ps3_gelic (Ethernet)) [1],
so I couldn't install it.

I did manage to install something using

`Unfortunately' I decided to give encrypted LVM a try. As it didn't install a
kernel, initrd, and bootloader config [1], the install was rendered unbootable.

First I tried to fix it manually:
  - Set up decryption and LVM from NFS root, and mount the file system
  - chroot to the mounted file system
  - install busybox-static from sid, to get a working grep [2]
  - install linux-image-2.6.29-2-powerpc64, which creates the initrd
However, the initrd complains it cannot find the volume group, and drops into a
shell after a while. From there, I can setup decryption and LVM and mount the
file system manually, though. Am I missing some important step?

Second, I tried to boot mini.iso in rescue mode, but it didn't detect any
encrypted volumes, so I couldn't recover. IIRC, resuce mode worked fine when I
tried it on my laptop (amd64) with encrypted LVM ca. one year ago.

Perhaps there are other issues with encrypted LVM on ppc?

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=514055
[2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=531600

With kind regards,

Geert Uytterhoeven
Software Architect
Techsoft Centre

Technology and Software Centre Europe
The Corporate Village · Da Vincilaan 7-D1 · B-1935 Zaventem · Belgium

Phone:    +32 (0)2 700 8453
Fax:      +32 (0)2 700 8622
E-mail:   Geert.Uytterhoeven@sonycom.com
Internet: http://www.sony-europe.com/

A division of Sony Europe (Belgium) N.V.
VAT BE 0413.825.160 · RPR Brussels
Fortis · BIC GEBABEBB · IBAN BE41293037680010

Reply to: