[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: NFS mounts: access rights problem

Hi Michel

On Wed, Feb 25, 2009 at 10:55:20PM +0100, Mich Lanners wrote:
> Hi,
> This is probably not really on topic here, so please excuse me...
> I'm banging my head against a NFS problem. Since recently, probably the
> last big Testing update on the NFS client, there is a problem with
> access rights to files on the NFS server.
> The client is only allowed to access according to "other" rights, as if
> uid/gid mapping between client an server doesn't work anymore. Although
> I use same uid/gids on client and server, a user cannot access his files
> on the server. Neither can root, although no_root_squash is in effect.
> I'm running v3, so no idmapd involved. It has always worked in the past.
> I have found no bug related to nfs-common.
> Does anybody have ideas to further debug this? Seen the same problem?

You probably need the sec=sys mount option on the client. The default
seems to have changed. I remeber there was a bug report about it, but I
can't find it right now. 


Ever tried. Ever failed. No matter.
Try again. Fail again. Fail better.
~ Samuel Beckett ~

Reply to: