[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem: update hell: apt-get gives segmentation fault consistently

Help requested please; thankyou in advance. I'm reasonably experienced with
Unix but not with Linux, so please
treat me as a newbie:

I'm attempting to upgrade the kernel on my linkstation box and I'm getting
a dreaded crash in apt-get.
When I run the webinstaller shell script it bombs out as copied-and-pasted

/latest-kernel.tar.gz.md5 [55/55] -> "latest-kernel.tar.gz.md5" [1]
--> kernel retrieved.
--> Getting modules... 15:32:36
modules.tar.gz [9281802/9281802] -> "latest-modules.tar.gz" [1]
/latest-modules.tar.gz.md5 [56/56] -> "latest-modules.tar.gz.md5" [1]
--> modules retrieved.
/usr/local/sbin/webinstaller-kernelinst.sh: line 248: 21855 Segmentation
fault      apt-get -y install module-init-tools

FATAL: Can't install Debian's module-init-tools, or lm-sensors (Tera only)
--> You need to take care of that yourself:
apt-get --reinstall install wget diff modutils module-init-tools # all
apt-get --reinstall install lm-sensors # Tera only
--> Then re-run the webinstaller.

So I then try and manually run the errant apt-get command and I get:
Buffalo400Gb:/tmp# apt-get -y install module-init-tools
Segmentation faultsts... 9%
Buffalo400Gb:/tmp# ls -lt /var/cache/apt
total 19800
-rw-r--r--  1 root root 1000000001 Feb 22 15:41 pkgcache.bin
drwxr-xr-x  3 root root      14336 Feb 22 09:39 archives
-rw-r--r--  1 root root   19169764 Aug 17  2007 available
Buffalo400Gb:/tmp# cat /etc/apt/apt.conf
APT::Cache-Limit "1000000000";

It looks as if I'm in update-hell: the updater is crashing out even after
pushing the cache limit up to
something ridiculous such as 1000000000 (== 1,000,000,000 ).

For the last two or three days I have revisited this problem sporadically. I
usually end up with half a dozen
firefox windows open on this laptop, each with a dozen tab pages following
any threads relating to this problem.
I've optimistically tried several variants in order to fix the problem,
hence I could have taken the machine
into a worse state. When all you have is a hammer, every problem seems like
a nail.

I'm even starting to doubt myself regarding the configuration: when I view
the debian_version it shows "5.0"
but I installed the box originally a couple of years ago and only recently
attempted the update.

So how do I extricate myself out of this mire: I'd love to obtain a working
"apt-get" that doesn't hit
a segmentation violation, but the only mechanism I know of to get a new
version is to use the existing
(broken) apt-get, hence I am in "catch 22" situation!

Any replies to the effect of "just restore the previous version" might prove
futile: some of the advice I
read was to clear out the cache hence I'm guessing that the backups have

Pragmatically, I use this little linkstation box as a third-level backup
disk: the main files are on my PCs,
I have a terabyte external hard disk as my backup media and I backup the
terabyte to the linkstation.
So the files on it are not *absolutely* important but I'd want to preserve
them if possible: no disk-formats
entertained at the moment.

Have got to the "totally p*ssed off" stage, I throw myself upon the mercy of
the newsgroup and humbly request
any help that is offered. If you need further data information then please
let me know.

Regards and thanks in advance

Mungo Henning

Reply to: