[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#514000: LINK_ARCH set to x86 with kernel > 2.6.23 regardless of KERNEL_ARCH

Package: kernel-package
Version: 11.015
Severity: important
Tags: patch

Hash: SHA1

The test syntax in the inner if statement for overriding LINK_ARCH to x86 is
incorrect in /usr/share/kernel-package/ruleset/targets/headers.mk, causing
LINK_ARCH to be set to x86 regardless of $(KERNEL_ARCH) with current
kernels. The attached patch fixes this.

- -- System Information:
Debian Release: 5.0
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'stable'), (102, 'experimental')
Architecture: powerpc (ppc)

Kernel: Linux
Locale: LANG=de_CH.UTF-8, LC_CTYPE=de_CH.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages kernel-package depends on:
ii  binutils            2.18.1~cvs20080103-7 The GNU assembler, linker and bina
ii  debianutils         2.31                 Miscellaneous utilities specific t
ii  dpkg                1.14.24              Debian package management system
ii  dpkg-dev            1.14.24              Debian package development tools
ii  file                4.26-2               Determines file type using "magic"
ii  gcc [c-compiler]    4:4.3.2-3            The GNU C compiler
ii  gcc-4.3 [c-compiler 4.3.3-3              The GNU C compiler
ii  gettext             0.17-6               GNU Internationalization utilities
ii  make                3.81-5               The GNU version of the "make" util
ii  module-init-tools   3.4-1                tools for managing Linux kernel mo
ii  perl                5.10.0-19            Larry Wall's Practical Extraction 
ii  po-debconf          1.0.15               manage translated Debconf template
ii  util-linux           Miscellaneous system utilities

Versions of packages kernel-package recommends:
ii  bzip2                         1.0.5-1    high-quality block-sorting file co
ii  libc6-dev [libc-dev]          2.7-18     GNU C Library: Development Librari

Versions of packages kernel-package suggests:
ii  docbook-utils             0.6.14-1.1     Convert Docbook files to other for
ii  e2fsprogs                 1.41.3-1       ext2/ext3/ext4 file system utiliti
ii  initramfs-tools [linux-in 0.92o          tools for generating an initramfs
pn  libdb3-dev                <none>         (no description available)
ii  libncurses5-dev [libncurs 5.7+20090124-1 developer's libraries and docs for
pn  linux-source | kernel-sou <none>         (no description available)
ii  xmlto                     0.0.20-5       XML-to-any converter

- -- no debconf information

Version: GnuPG v1.4.9 (GNU/Linux)

--- /usr/share/kernel-package/ruleset/targets/headers.mk.dpkg-dist	2008-12-29 13:36:41.000000000 +0100
+++ /usr/share/kernel-package/ruleset/targets/headers.mk	2009-02-03 08:27:55.000000000 +0100
@@ -32,7 +32,7 @@
 ifeq ($(shell if [ $(PATCHLEVEL) -eq 6 ] && [ $(SUBLEVEL) -gt 23 ] ; then \
-	    if [ $(KERNEL_ARCH)=="i386" ] || [ $(KERNEL_ARCH)=="x86_64" ] ; then \
+	    if [ $(KERNEL_ARCH) = "i386" ] || [ $(KERNEL_ARCH) = "x86_64" ] ; then \
 	         echo "yes" ; fi ; fi ),yes)

Reply to: