[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian on a Thinkpad Power Series 820

>     * From: "Pedro Rey" <prey@reyland.es>
>   I'm trying to install Debian on a Thinkpad Power Series 820 machine PReP architecture with
>   a 603e PowerPC processor, with no luck at the moment.
>   So far, I've tried to boot the 4.0_r5 install CD, but the laptop hangs while booting.

I have a 7248/100 (like the one in http://pauli.borodulin.fi/hw/43P-7248/)
with woody and a 2.4.19 kernel that I found precompiled un the net; I
suspect that for installation I used (it was 2002/2003ca I think)


Your machine might be not _too_ different from mine.

Recently I added a ide disk to my machine, with among the partitions a
copy of sarge and etch installations which I use on beige g3 powermacs,
and these installs work in a chroot of the woody install (which is on
the scsi disk). However, to use also a lenny chroot a 2.6.x kernel is

Today I downloaded


I did a 

dd if=vmlinuz-prep.initrd of=/dev/hda1

(hda1 is the bootable PReP type 41 partition on the ide disk) 

and at the reboot, I pressed F2 after the firmware ckecked the keyboard
(but before it ended the ckeck of the ram), and then instead of booting
from sda1 (as usual) the firmware gave me a textual menu to chose the
booting device. I booted from the ide disk. 

What happened is quite similar to your case.

The usual messages pre-kernel-boot appare, and then all *seems* to hang.

For my good (?) luck I forgot to reset the machine (I had other things to do).

After ten minutes or so the kernel suddntly booted. 

And then it stopped (after many many lines) at

Freeing unused kernel memory: 124k init
SCSI subsystem initialized
PCI: Enabling devuce 0000:00:10.0 (0000 -> 0003)
sym0: <810> rev 0x2 at pci 0000:00:10.0 irq 9
sym0: No NVRAM, ID 7, Fast-10, SE, parity checking
sym0: SCSI BUS has been reset.
scsi0 : sym-2.2.3

After ten minutes or so another kernel line:

scsi 0:0:0:0: ABORT operation started.
After ten minutes or so other two lines:

scsi 0:0:0:0: ABORT operation timeed-out.
scsi 0:0:0:0: DEVICE RESET operation started.

Other ten minutes or so and then:

scsi 0:0:0:0: DEVICE RESET operation timeed-out.
scsi 0:0:0:0: BUS RESET operation started.

You guessed what, and then:

scsi 0:0:0:0: BUS RESET operation timeed-out.
scsi 0:0:0:0: HOST RESET operation started.
sym0: SCSI BUS has been reset.

again ...

scsi 0:0:0:0: HOST RESET operation timed out.
scsi 0:0:0:0: scsi device offlined - not ready after error recovery

At this point I will leave the machine alone and in a few (?) hours I
will see where the booting process will be.

In any case it seems that debian precompliled 2.6.18 prep installation kernel
does not like the sym0 controller on the machine.

I will have to recompile a recent 2.6.x kernel with a configuration
"like" the 2.4.19 that I have (I think it is the one at the first http
site above) and the patches for the e15 framebuffer (like the ones at
the geocities or abcompcons sites for the 2.4.x kernel). This will be
quite "interesting", given the many changes from 2.4.x to 2.6.x and the
fact that 2.6.27 no more has the ppc tree (only the powerpc tree, which
however has worked for at least one PReP machine according to the
mailing lists archives at http://ozlabs.org/pipermail/linuxppc-dev/ )

Reply to: