[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ppc installation issues...


Here are some of the issues that I faced while installing and
upgrading debian on my iBook G4: (if I am writing to the wrong list,
please let me know)

$ cat /proc/cpu
processor       : 0
cpu             : 7447A, altivec supported
clock           : 1199.999000MHz
revision        : 0.2 (pvr 8003 0102)
bogomips        : 73.47
timebase        : 18432000
platform        : PowerMac
machine         : PowerBook6,5
motherboard     : PowerBook6,5 MacRISC3 Power Macintosh
detected as     : 287 (iBook G4)
pmac flags      : 0000001b
L2 cache        : 512K unified
pmac-generation : NewWorld

1. KDE as a desktop while installing Etch - there is no option to
install KDE as the desktop manger, instead of Gnome. Surprisingly, at
the tasksel stage of the installation process (even in "expert") mode
there is no mention that the "Desktop environment" is actually GNOME
and only GNOME!! Note that, I have tried the netinst, xfce-cd-1, and
kde-cd-1 discs from this page:
http://cdimage.debian.org/debian-cd/4.0_r1/powerpc/iso-cd/ and each of
these installs Gnome (xfce does xfce though). More agonisingly, even
after adding "task=standar, laptop, kde-desktop" at the boot prompt of
the installer I end with a GNOME!! Why? What is the purpose of
*-kde-cd-1.iso? Why is there no simple option to choose between
Gnome/KDE at the tasksel stage?

OK, so even after repeated formats and installations, I end up with a
Gnome DM - fine, I'll change to kde later....

2. I upgraded to unstable, using dist-upgrade, and the locale is
screwed.... To be fair to the Debian folks, I was surprised and
impressed to find that almost everything else worked fine, if not
better, after the dist-upgrade. Anyway as of now,  apt-get <cmd> gives
the a combination of the following two error:

perl warning: Please check that your locale settings
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_US"
are installed on your system


locale:cannot set LC_CTYPE to default locale: no such file or directory
locale:cannot set LC_MESSAGES to default locale: no such file or directory
locale:cannot set LC_ALL to default locale: no such file or directory

As expected the locales package is broken... Is this the situation, or
is it because of my dist-upgrade? What is the fix?

http://counter.li.org  #402424

Reply to: