[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: major problem booting Debian GNU/Linux 4.0 on a Workgroup Server 8550/200

Hello Pierre,

Hi there,

After several installation attempts, I am stuck with a very weird problem.
The machine is a Workgroup Server 8550/200.
There's MacOS 9.0.4 on it, and remaining free space on the disk.


When Debian GNU/Linux 4.0 is installed, well, the only thing left to do is to boot it.
And here comes the major problem.

I'm using BootX to boot with the following parameters:
(see the little screenshot at http://pierre.baudu.in/files/20070424_BootX.jpg )

- kernel: vmlinux-2.6.18-4-powerpc
- force video settings: enabled
- use specified ramdisk: initrd.img-2.6.18-4-powerpc
- ramdisk size: 8192
- no video driver: enabled
- more kernel arguments: root=/dev/sda10

But booting still fails, now the message is:
VFS: Cannot open root device "sda10" or unknown-block(0,0)
Please append a correct "root=" boot option

But /dev/sda10 is there ! And Debian 4.0 was working properly on it since it installed flawlessly.

This is puzzling.

Any help would be appreciated

Thank you,

As I read this I do remember that I run into the same problem some days ago but thought that I did something wrong. I noticed that there was an updated 2.6.18 kernel installed and as an OW Mac user, if you like to run it, copy it first. Mounted the MacOS9 scsi disk and copied the whole /boot dir to MacOS. I even checked the right settings of BootX on MacOS9 to make shure the new kernel has been picked. I noticed somehow that there was no initrd with the old one. Strange thing.

When I used the brand new 2.6.18 kernel and initrd my beige G3 comes up with the same error. To my luck I found one of the outdated kernel, still 2.6.18-4. But this one has no initrd. And it worked. 

The only help I can offer is to confirm the problem.


Attachment: PGP.sig
Description: Signierter Teil der Nachricht

Reply to: