[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Try again : Linux X server issue with Powerbook G4 15'

Yves-Alexis Perez a écrit :
On Tue, 2006-10-24 at 09:34 +0200, Mathieu Rigard wrote:
Hi there,
I've just install Debian Etch on my Powerbook G4 800MHz. Netinstall
with video=ofonly whas ok and all sims to be ok but when Etch try to enter runlevel 5 and start x, my screen turn ok and black.
I can't go in a shell for see my Xorg config because i don't now howo
to stop in 4 or 5 runlevel and the Ubuntu ppc give me the same issue even in video=ofonly.
If someone has an idea....
Try to boot with "single" argument to kernel so it doesn't try to run
gdm. Remove /etc/X11/default-display-manager. Reboot, gdm isn't run,
you're at the console. Try to startx and see the logs.

You could also try to login via ssh and see X /var/log/Xorg.0.log

Could you attach your xorg.conf too ?

OK, Thank you Yves-Alexis, for the "single" Boot argument !
I have see my /var/log/Xorg.0.log.
I have  :
(WW) .../fonts/... directory does not exist (for all my fonts).


(WW) ******INVALID IO ALLOCATION********* b: 0xf0000400 e: 0xf00004ff
(EE) end of block range 0xefffffff  begin Oxf0000000

But i don't know what it mean ?!!

I can't give you all the log (i don't find howo to send it in text mode)

I modify my Xorg.conf for change Section "Monitor" in HorizSync 28-48 (then 28-64, then 28-33 then 30_130) and VertRefresh 43-72 (then 43-60, then 50-160) with no result...

When I have my black screen (after doing startx in root) I can have a little bit of color and light with Ctrl-F8...

I'm in trouble ;o)



Reply to: