[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#382129: Is now a good time to revisit installer not booting on OldWorld PowerMac beige G3?




On Sep 16, 2006, at 3:05 PM, Sven Luther wrote:

On Sat, Sep 16, 2006 at 09:50:03AM +0200, Frans Pop wrote:
On Saturday 16 September 2006 09:09, Rick Thomas wrote:
Is there someone out there who will work with me to get a kernel that
boots to run debian-installer on my beige G3 PowerMac (OldWorld)
machine?

I'd like to see that happen.

If not, I think it may be time to withdraw OldWorld PowerMacs from
the list of hardware supported by the Debian Installer.

Note that as I understand there are also problems booting the kernel
outside the installer (i.e. just upgrading an installed system), this
does not seem to be a Debian Installer issue, but rather a powerpc kernel
or kernel configuration issue.

Its actually a problem with the ramdisk generators and/or bootloaders, not the
kernel proper.

Actually, from the symptoms I'm seeing, it may not be getting far enough to encounter ramdisk problems. (Not to say there are no such ramdisk problems, just that what I'm seeing is not diagnostic for them.) I gave fairly detailed notes in the previous bug report, Bug#382129. Let me know if you want more information.

If Sven is right, that leaves bootloaders.

However, I'm not completely convinced yet that it's not a kernel configuration problem. My evidence for this is that the miboot floppy with a 2.6.16 kernel on it will boot and read it's ramdisk floppy. From this I conclude that it is *possible* to build a 2.6.16 kernel (and by inference, a 2.6.17 kernel) that will boot an OldWorld machine. If so, the only question is whether such a configuration is acceptable as a general-purpose kernel for PowerMac machines, including NewWorld?

Rick




Reply to: