[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Is now a good time to revisit installer not booting on OldWorld PowerMac beige G3?

Is there someone out there who will work with me to get a kernel that boots to run debian-installer on my beige G3 PowerMac (OldWorld) machine?

As I reported in Bug#382129 regarding the Linux-powerpc 2.6.16 kernel not booting on my OldWorld test machine, I now find that the 2.6.17 kernel in the latest daily d-i ISOs also will not boot on OldWorld. The console messages are essentially the same as in Bug#382129. As expected, It boots OK on my G4 NewWorld test machine.

Recently, there was an email from someone who managed to configure a 2.6.16 (I think it was) kernel that would boot on his OldWorld machine. It involved making the ide disk driver resident, I think.

I'm not a kernel hacker, so I can't do that part myself. But I've got hardware I can test things on, and I'd be willing to give someone who knows what they are doing an account on one of those machines if they will work with me on solving this problem.

Any takers?

If not, I think it may be time to withdraw OldWorld PowerMacs from the list of hardware supported by the Debian Installer.


Reply to: