[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Strange problem with linux-image-2.6.17-2-powerpc

Denis Fernandez Cabrera wrote:

Hello everyone,

I have a really weird problem: I have installed a new linux kernel image, 2.6.17-2-powerpc, from Sid in my iBook, because it has Airport Extreme support (it works, BTW!).

When I boot with 2.6.17, everything is fine, including the wireless... *Except* I can't do an SSH outside of my LAN. I can SSH to (my PC) but I can't SSH to ceibes.org (my web host) or do telnet, FTP, or SMTP to outside machines.

It looks like a configuration problem, isn't it? Perhaps the router?

Well, it isn't. Because if I boot with the previous kernel (2.6.16) the SSH works perfectly fine (as it used to), as do telnet, FTP, SMTP et al. But, of course, Airport won't work.

Does anybody have any clue as to what may be happening here? I'd appreciate any suggestion, guess and whatnot, because I am totally at a loss of ideas in this regard.

Thanks in advance,

P.S.: Oh, and it is not a specific problem of the Debian packaging of this kernel image, because I have tried to compile a clean kernel ( from kernel.org) and I get the same odd behavior.
I suspect that this strange behaviour with the 2.6.17.XXX kernels is of the same origin like the one I have noticed some time ago with also with secure services especially IMAPs and POP3s. I could not take email from specific imaps and pop3s accounts with the connection timing out. Also somewhere else I think that I saw
some reports about SSH as well.

From personal conversation, David Elze looked into it and he came up with
a trick that in my case solves the problem
(which from his analysis seems to relate with a recent change in the handling of network
packet buffers with the 2.6.17.XXX kernels). See his reply :

I 've solved the problem for my case, should work for you also:

Just try to boot 2.6.17.x and execute this:
# echo 4096 87380 174760 > /proc/sys/net/ipv4/tcp_rmem

If this solves your problem then the following should be fairly interesting for you: http://kerneltrap.org/node/6723


in further inspection it may be an issue with firewalls or some
intermediate switches and so on which are not for some reason
compatible with these changes in the Linux kernel's network handling (for instance looks PF in OpenBSD doesn't like it at all!). But there is not yet a decisive explanation. So until
then you may try the "hack" and see if it does the job for you as well!

hope it helps

emmanuel galatoulas

Reply to: