[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: video problem with bootx on 7200

have search google and what i see not helping much:
one recent success like yours and a failures w/miboot.

but have you tried 

a) disable all extension (shift key down at macos
startup). saw report you could not use bootx extension
at startup with 7200 right ? (would be good to try
because with the bullet in front of the name it loads
early, i bilieve).

b) pull your extra 1MB VRAM. just a thought, why not
try it.

c) there was one report someone using aty video. i
assume that means a pci card. no details.

d) all your 7200 parts, except for motherboard, are
compatible with several later models ...
so you have some options there - parting out or
replacing motherboard maybe.

e) try installing woody.

f) try patching open firmware (this of = v 1.)

g) try the current kernel for sarge (i don't
know what happened but you listed an older one)

--- "J. R. Harvey" <harvey@pinn.net> wrote:

> I installed debian sarge on a powermac 7200/120.
> When it boots with
> bootx, the video doesn't work. The logo shows up
> briefly, then the
> screen goes blank while it finishes booting, and
> stays blank. Everything
> else seems to be working, so I can log in via ssh. I
> didn't install X,
> so all I'm concerned about is having video work for
> the console.  (The
> video did work fine with bootx and the installer.)
> I've tried checking and unchecking both the no video
> driver and force
> video settings, and I've tried using various kernel
> arguments to match
> the display settings like:
> video=platinumfb:vmode:12,cmode:2
> The video works when I boot with quik, but I'd like
> to get it to work
> with bootx because I'm eventually going to give the
> machine away and
> bootx seems like it would be easier for a novice to
> use to switch
> between OS 9 and linux. One strange thing happens
> when I boot with quik,
> after the logo appears, it looks like the boot
> messages might be
> appearing in a tiny square about the same size as
> the logo right under
> the logo. It looks like tiny white lines are
> flashing by.  Then when it
> finishes, the screen resets and the login message
> appears.
> Here are some details about the installation. The
> 7200 has 64mb ram, and
> two 1gb internal hard drives. It's an installation
> from the sarge
> installer.  uname -a shows:
> Linux debian7200 2.6.8-powerpc #1 Thu Nov 24
> 00:17:15 UTC 2005 ppc GNU/Linux
> I tried to install with floppies, but my floppies
> are all old recycled
> ones and I'm not confident the floppy drive is in
> good working order.
> After 3 or 4 tries at making different floppy images
> I gave up.  I ended
> up using the debian-31r2-powerpc-netinst.iso with
> bootx on OS 9.1 which
> I installed on one of the 1gb scsi drives.  I used
> the vmlinux installer
> kernel (referenced as linux.bin in the powerpc docs)
> and initrd.gz
> ramdisk (referenced as ramdisk.image.gz in docs) in
> /install/powerpc/ to
> start the installer with bootx by selecting the
> ramdisk option.  The
> video works with the installer, and I installed
> debian on the other 1gb
> internal, including quik (I changed the default ext3
> fs to ext2 so quik
> would work without making a separate boot
> partition), and I was able to
> boot into linux with quik, and as I mentioned, the
> video worked.
> I mounted the hfsplus mac partition and copied the
> vmlinux-2.6.8-powerpc
> kernel and initrd.img-2.6.8-powerpc ramdisk from the
> /boot directory to
> the Linux Kernels directory on the hfs+ partition,
> then rebooted into
> mac os.  I eventually figured out that it would boot
> from bootx without
> any kernel arguments if I selected the 2.6.8 kernel
> and 2.6.8 ramdisk,
> but the video wouldn't work with any combination of
> checking video
> options or entering kernel arguments for the video.
> I tried rebooting into mac os and setting the
> monitor resolution to
> various combinations of 640x480, 800x600, 832x624
> and various color
> depths, but the screen would always go blank shortly
> after the logo
> appeared, except with 8 bit monitor settings. 
> Strangely, when I set the
> color to 256 colors and tried to reboot, the logo
> would appear and the
> machine would hang, eventually auto-rebooting back
> into mac os.
> Here are a few lines from the syslog from a quik
> boot, where the video
> worked, then a few lines from a bootx boot, where
> the video doesn't
> work:
> quik, video works:
> Aug 30 22:36:16 localhost kernel: platinumfb: Found
> Apple Platinum 
> video hardware
> Aug 30 22:36:16 localhost kernel: platinumfb: Total
> VRAM = 2MB (0011)
> Aug 30 22:36:16 localhost kernel: platinumfb: DACula
> type 0x84
> Aug 30 22:36:16 localhost kernel: platinumfb:
> Monitor sense value = 
> 0x717, platinumfb:  Using video mode 5 and color
> mode 1.
> Aug 30 22:36:16 localhost kernel: fb0: Apple
> Platinum frame buffer device
> bootx, video does not work:
> Sep  3 01:41:53 localhost kernel: MacOS display is
> /platinum
> Sep  3 01:41:53 localhost kernel: Using unsupported
> 800x600 platinum 
> at f1001020, depth=16, pitch=1632
> Sep  3 01:41:53 localhost kernel: fb0: Open Firmware
> frame buffer 
> device on /platinum
> Sep  3 01:41:53 localhost kernel: Thermal assist
> unit not available
> Sep  3 01:41:53 localhost kernel: platinumfb: Found
> Apple Platinum 
> video hardware
> Sep  3 01:41:53 localhost kernel: platinumfb: probe
> of platinum 
> failed with error -6
> When I connect to the machine with ssh after booting
> with bootx, no
> matter what I've set the monitor's resolution to in
> mac os and given as
> kernel args, fbset shows:
> mode "800x600-186"
>      # D: 100.000 MHz, H: 119.048 kHz, V: 186.012 Hz
>      geometry 800 600 800 600 32
>      timings 10000 16 16 16 16 8 8
>      rgba 8/16,8/8,8/0,8/24
> endmode
> When I try to use fbset to change the mode, I get no
> error message, but
> the mode doesn't really change.
> My monitor is a Sony multiscan17sf with a VGA
> adapter to work with the
> mac. I was going to try connecting an old 14" apple
> monitor and see if
> that might make a difference, but I haven't tried
> that yet.
> -- 
> To UNSUBSCRIBE, email to
> debian-powerpc-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact
> listmaster@lists.debian.org

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

Reply to: