[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Trouble getting mac mini builtin modem to work

Hi everybody!

I am trying to get the built-in modem of my mac mini to work (if only
for nostalgic purposes :), but no luck so far...

This is what linux sees:

Linux venus #1 PREEMPT Tue Mar 7 21:37:17 CET 2006 ppc GNU/Linux

ttyS0 at MMIO 0x80013020 (irq = 22) is a Z85c30 ESCC - Serial port
ttyS1 at MMIO 0x80013000 (irq = 23) is a Z85c30 ESCC - Serial port

The devices appear nicely (thanks, udev :) in /dev:

crw-rw----  1 root dialout 4, 64 2006-03-09 08:06 /dev/ttyS0
crw-rw----  1 root dialout 4, 65 2006-03-09 08:00 /dev/ttyS1

And now the tricky part... I've tried minicom on both serial ports, and
with the whole bunch of baud rates, but no luck. No response at all from
the ports. Which makes me think that, perhaps, the built-in modem is not
connected to any of these serial ports? If so, why on earth would apple
add two serial ports connected to nothing but air (there are no serial
connectors in the rear plate)? :-) Hey, legacy stuff in mac? :-P

Indeed, I have no idea whether the built-in modem is a softmodem or not.

Anybody has experimented with this? any ideas would be very appreciated.

Nice piece of hardware, this mac mini. Working in almost complete
silence is priceless for me...

And thanks to the contributors of this list; with the info I gathered
from here I got it working with no hassle, even the sound mixer issue
was solved in this list!

Thank you,


Pancho Horrillo

To be conscious that
you are ignorant is a great step
to knowledge.

		Benjamin Disraeli

Attachment: signature.asc
Description: Digital signature

Reply to: