[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Compile 2.6.16-rc2 + bcm43xx-dscape fails looking for vmlinux.coff

Hash: SHA1


I've tried and failed about a dozen times to compile a 2.6.16 release
candidate kernel with the associated bcm43xx-dscape patches. I think the
problem is Debian or Powerpc related (or kernel config) and not the
fault of the driver.

The most common error I see comes after the kernel appears to have
(almost) compiled OK but cannot find vmlinux.coff:

cp arch/ppc/boot/images/vmlinux.coff
cp: cannot stat `arch/ppc/boot/images/vmlinux.coff': No such file or
make[1]: *** [real_stamp_image] Error 1
make[1]: Leaving directory `/usr/src/linux-2.6.16-rc2'
make: *** [kernel-image-deb] Error 2

I got the kernel to compile twice by doing this:

touch arch/ppc/boot/images/vmlinux.coff
(just before make-kpkg --append-to-version=.###### kernel_image )

but the resulting kernels would not boot, nor give errors. They just
froze before the Tux logo ever appeared.

I wrote an extremely detailed description of the steps I've taken in the
Installation support forum at http://bcm43xx.spugna.org (which appears
to be down right now).

I think my .config is the problem. I have a post-Feb-2005 12" Powerbook
with Nvidia and the wacky touchpad that I still cannot make work. (If
anyone can write a HOWTO for that detailed enough for a dummy, I'd
appreciate that too.)

My latest .config is at http://sharealike.org/config-2.6.16-rc2.060214.txt

it's based on a Debian user with an iBook and ATI card who said he got
dscape compiled on a 2.6.16 rc so I tried to change his config as little
as possible and got the above. Still no luck. If anyone sees the problem
in this config or can suggest a simpler way to make the bcm43xx driver
work on this Powerbook (explain in cut-and-paste simple steps!) then I'd
be very thankful.

(Feel free to reply both on and off list).
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org


Reply to: