[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.6.15 doesn't see ide disks -- very bad [WAS: system hosed by udev in dist-upgrade]

Matt Price wrote:
On 1/22/06, Matt Price <moptop99@gmail.com> wrote:

On 1/22/06, Linas Zvirblis <0x0007@gmail.com> wrote:

Try running MAKEDEV, it should give all the missing devices the old
fashioned way. If that does not work, "mknod /dev/hda b 3 0".

tried this with no success -- /dev/hda10 still doesn't get recreated.

Let me reiterate the main problem -- I tried to dist-upgrade my system
(debian sid, about 6 months outdated, running on a blue & white Mac
g3), and when udev wouldn't install, I apt-getted a newer kernel to
try again; rebooted, & now my system doesn't find /dev/hda -- which is
where my /var is located, which means apt-get doesn't work at all, so
udev can't be installed...

Trying to do a better job of diagnosingthis problem.

I no longer think the problem is with udev per se, despite the fact
that a udev incompatibility is what helped make the system unusable. I tried booting with my old (2.6.10) kernel & found that the system
boots properly, that hda is found & the relevant partitions mounted, &
that my ethernet is recognized & mounted.  So the problem -- that,
while my scsi disks are recognized & mounted, my IDE disk isn't, and
my ethernet isn't found --  is presumably to do with the stock
2.6.15-powerpc I installed in an effort to get udev installed & my
dist-upgrade complete.  Unfortunately I do still need this kernel, so
that I can finish my system-destroying dist-upgrade.

I'm not sure how to proceed.  my old kernel, 2.6.10, runs fine, but
udev still blocks my dist-upgrade.  I would try building a new 2.6.15
kernel based on my 2.6.10config, but the system is so badly screwed up
right now (e.g. even gcc is only partly installed) that I don'tthink
things like make-kpkg are working.

so I'd appreciate help on either of 2 solutions:
1 - find a wayto downgrade udev & undo the dist-upgrade, which I can
temporarily put off until I get a 2.5.12+ kernel to work properly.
2 - with the system in this somewhat messed up state, figure out
what's wrong with the 2.6.15 kernel & fix it somehow

I'm not especially optimistic -- but thanks for any help you canoffer!


ps, in case anyone's wondering, I did look a little at my config-2.6.x
files.  while idedisk support is compiled into my old kernel, it's a
module in the new, stock kernel; however, I used modconf successfully
to add idedisk tothe running kernel; installation succeeded, but
/dev/hda still wasn't recognized.    I should perhaps say that my
system was already screwed when I installed
linux-image-2.6.15-1-powerpc, & I had to manually wget & dpkg -i
various kernel tools -- yaird & some mkinitrd tools as I recall. don't know if this is the root or the problem.

There have been some problems with yaird IIRC so this may be your problem. Although I thought it was fixed now (dont use initrd).

Couple of things to try.

1) boot from live cd and compile a kernel with 2.6.15 sources.
2) Grab a older kernel from testing >2.6.12 and dpkg-i that.

2) is probably easier.



Reply to: