[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: IBMJava doesn't work after installing... - solution!


Gong Jie wrote:

> The same thing happen to me.  I think this is a debian java-package bug.

Yes in fact it is - see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=338569 as suggested by Ruben.

> Here is my work around solution.  Remove all the java stuff under
> /usr/bin, 
> and re-create them.

I did it another way. I uninstalled ibm java
apt-get remove ibm-j2re1.5 java-package
apt-get install java-package
downloaded java-package.patch (see bug 338569)
cd /usr/share
patch -p0 <java-package.patch
cd /home/bla/ibmjava (where ibm tgz file is downloaded)
(as user)
fakeroot make-jpkg ibm-java2-jre-50-linux-ppc.tgz
(as root)
dpkg -i ibm-j2re1.5_1.5.0_powerpc.deb
put path to Java in Konqueror (/usr/bin/java)
logout, login
and JavaJVM works fine!!

> BTW, there is a mozilla plugins in IBM Java 1.5.  So you can watch java
> applet 
> with mozilla or firefox.  Just create the symbolic links as the
> following.
> ~~~snip~~~
> ln -s /usr/lib/j2sdk1.5-ibm/jre/bin/libjavaplugin_oji.so \
>     /usr/lib/mozilla/plugins/
> ln -s /usr/lib/j2sdk1.5-ibm/jre/bin/libjavaplugin_oji.so \
>     /usr/lib/mozilla-firefox/plugins/
> ~~~snip~~~

Strange but it doesn't work for me. JVM in Mozilla and Firefox is still broken. Any ideas??
How to check which plugins are installed in Mozilla/Firefox??
BTW: why j2sdk1.5-ibm ?? I have /usr/lib/j2re1.5-ibm/jre/bin/libjavaplugin_oji.so. Is it the same plugin??

Best regadrs,
Bartosz (Bazant) Sokolowski
PegasosII G4/1000 powered by Radeon8500
MOS, Debian > MOL user

Reply to: