[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

problems installing debian on Performa 6400

I have been attempting to follow the instructions in


to install debian on my Performa 6400/180.
I have done the following:
1. created 2 partitions on my hard disk, one with the Mac OS installed, the other blank
2. installed bootx
3. downloaded CD images from http://cdimage.debian.org/debian-cd/3.1_r0a/powerpc/jigdo-cd
(I am using a Windows XP machine to download and burn- I don't have an internet connection on the Performa- the modem is not functioning)
4. burned the first CD using Nero
5. copied vmlinux and initrd.gz (from the PowerPC folder on the debian distro) into a Linux Kernels folder under the System folder

(Actually the instructions say
|linux.bin| and
|ramdisk.image.gz| from the
|disks-powerpc/current/powermac| folder, and place
them in the |Linux Kernels| folder."
but I can't find those files, so I tried using the files for the New World Macs (vmlinux and initrd.gz), which are present in my distro)
When I reboot, I see the BootX dialog.  There is no response when I
select "Use RAM Disk"
If I click on Linux, I get a console screen and see some welcome to linux stuff, but it fails at
VFS: Cannot open root device "<NULL>" or unknown-block(8,1)
Please append a correct "root=" boot option
Kernel panic VFS: Unable to mount root fs on unknown-block(8,1)
<0>Rebooting in 180 seconds..

which it does.
Clearly I am missing something important.. can anyone give me a clue?
Are there |linux.bin| and| ramdisk.image.gz files somewhere I haven't looked yet?

|Thanks, Tara

PS I have OS 7.5.3 installed on the Mac.

Reply to: