[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

d-link dwl 122 workin?

Hey everybody.
Momentarily I'm running a Kubuntu Linux, but I will return soon to Debian, 
strangely a lot of applications are quite unstable and in the forums there 
does not seem to be lots of activity...
Anyway I fear that my problem I had also under Gentoo and now under Kubuntu 
(5.10) will persist with Debian again: a wireless lan usb-adapter.
I bought a D-Link DWL-122 because I had read in a couple of forums that it may 
work with linux, it's based on a prism2-chip supported by linux-wlan-ng.
Now indeed I get this result:

bjosch@Aemilia:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:0D:93:AF:0C:74
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::20d:93ff:feaf:c74/64 Scope:Link
          RX packets:9048 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5158 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:9115767 (8.6 MiB)  TX bytes:640362 (625.3 KiB)
          Interrupt:41 Base address:0x4400

lo        Link encap:Local Loopback
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:52 (52.0 b)  TX bytes:52 (52.0 b)

sit0      Link encap:IPv6-in-IPv4
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wlan0     Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

Also in KInfo it shows up correctly. But KWifiManager is of no help, it seems 
not to find. So I tried with the configs but maybe I messed them only up, 
anyway it does not work. Here the configs:

# [Dis/En]able WEP.  Settings only matter if PrivacyInvoked is true
lnxreq_hostWEPEncrypt=true     # true|false
lnxreq_hostWEPDecrypt=true     # true|false
dot11PrivacyInvoked=true   # true|false
dot11WEPDefaultKeyID=0      # 0|1|2|3
dot11ExcludeUnencrypted=true   # true|false, in AP this means WEP is required.

# If PRIV_GENSTR is not empty, use PRIV_GENTSTR to generate
#  keys (just a convenience)
# add-ons/ in the tarball contains other key generators.
PRIV_GENERATOR=/sbin/nwepgen   # nwepgen, Neesus compatible
PRIV_KEY128=false      # keylength to generate

# or set them explicitly.  Set genstr or keys, not both.
dot11WEPDefaultKey1=[here is my correct key]      # format: xx:xx:xx:xx:xx   
dot11WEPDefaultKey0=      #         xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx
dot11WEPDefaultKey2=      #  e.g.   01:20:03:40:05   or
dot11WEPDefaultKey3=      #         01:02:03:04:05:06:07:08:09:0a:0b:0c:0d
#=======SELECT STATION MODE===================
IS_ADHOC=n          # y|n, y - adhoc, n - infrastructure

#======= INFRASTRUCTURE STATION  ===================
# What kind of authentication?
AuthType="opensystem"      # opensystem | sharedkey (requires WEP)

#======= ADHOC STATION ============================
BCNINT=100         # Beacon interval (in Kus)
CHANNEL=9         # DS channel for BSS (1-14, depends
            #   on regulatory domain)
BASICRATES="2 4"      # Rates for mgmt&ctl frames (in 500Kb/s)
OPRATES="2 4 11 22"      # Supported rates in BSS (in 500Kb/s)

/etc/wlan/wlan.conf (abbreviated):
#! /bin/sh
# Wireless LAN adapter configuration


# Below is the list of channels to scan, when we scan.
# Below is the min and max time we linger on a channel during a scan.
# And here we have the master scan toggle.


A "dmesg" gives me this:
[ 1650.792169] p80211req_dorequest: wlan0: only dot11req_mibget allowed for 
[ 1659.701331] hfa384x_usbctlx_complete_sync: CTLX[3] error: state(Request 
[ 1659.701345] prism2sta_getcardinfo: Failed to retrieve NICIDENTITY
[ 1659.701349] prism2sta_getcardinfo: Failed, result=-5
[ 1659.701356] prism2sta_ifstate: prism2sta_getcardinfo() failed,result=-5
[ 3239.775775] usb 1-1.1: USB disconnect, address 3
[ 3242.925670] usb 1-1.1: new full speed USB device using ohci_hcd and address 

I wished it might be a bit easier, I read a lots of post in forums and docus, 
I tried to change some values in the configs but when I do something like 
iwconfig, it's always the same result:

bjosch@Aemilia:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.

wlan0     no wireless extensions.

Can anybody give me a "practical" advice? Thanks in advance.

Composed and sent with KMail on Kubuntu Linux (PPC)
GPG Key fingerprint: B5CF 41E6 7AA1 3D3D 17BA 4B8F 0331 87D4 E4CA 1768

Yahoo! Messenger: chiamate gratuite in tutto il mondo 

Reply to: