[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: Powermac G5 yaboot install failed

Thanks guys. Shyamal or Sven can you walk me through the fix? If I don't
get this working I have to return the G5 to the store.

I am assuming that I need to mount the root drive while booted off the
cd,  and copy in <something> or change the yaboot.conf or both?

also in ref to bug #339561  I have SATA 150 drives, not SCSI, though I
think maybe they modified the scsi driver to do ide? 

Further info on this machine: the latest 32 bit kernels I tried - from
debian, fedora, ydl won't load at all. Only the 64 bit kernel from YDL
and Debian load. I couldn't get the YDL package to work with our
software. I can't actually tell if this is entirely kernel related or if
Apple also has some hardware in the G5 dual-proc that makes a


> >>>>> "Sven" == Sven Luther <sven.luther@wanadoo.fr> writes:
>     Sven> On Fri, Dec 02, 2005 at 04:50:26PM -0800, john fisher wrote:
>     >> 
>     >> new, non-dual core, dual-proc 2.0 PowerMac G5 latest testing
>     >> debian ppc netinstall ( 11-28)
>     >> 
>     >> 
>     >> 1) install base system, chose default kernel 2) write yaboot to
>     >> hard disk: error: "failed to install boot loader"
>     >> 
>     Sven> File a bug report against yaboot-installer describing your
>     Sven> problem, maybe using the installation report template, but
>     Sven> modifying the Package: field to show yaboot-installer.
> Hi Sven, John,
> IMHO this problem seems related to ofpath in etch not getting /dev/sd*
> open firmware names correct with 2.6.12 and later kernels. See #321962.
> I've already filed #339561 on this issue but perhaps no one noticed
> it. My hardware is exactly the same as Johns as far as I can tell. The
> ofpath problem is easily solved by using the version of yaboot in sid
> on my machine.
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=339561

John Fisher at Znyx Networks
Santa Barbara office

Reply to: