[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

kernel 2.6.8 and 2.6.12 fail to boot on blue&white G3

I just installed debian on a blue and white G3 (another story in itself, 
see my next email), and tried to install a 2.6 kernel, both 
kernel-image-2.6.8-powerpc from stable, and 2.6.12 from testing.  Both 
kernels panic when trying modprobing the cmd64x ide driver in their 

I had to capture the messages by hand, and this is what I got, booting 
the 2.6.8 kernel in stable:

DAR: BD9D377E, DSIR: 40000000
TASK = cfe12000[156] 'modprobe' THREAD: cff3a000Last syscall:128
NIP: [c00fbd14] ide_inb+0xc/0x24
LR: [c01026a8 ide_get_or_set_dma_base+0xa8/0x1a4
Call trace:
 [c0102c90] ide_hwif_setup_dma+0x84/0x154
 [c0103020] ide_pci_setup_ports+0x190/0x1f0
 [c010314c] do_ide_setup_pci_device+0xcc/0x1a0
 [c0103244] ide_setup_pci_device+0x24/0x88
 [d18386a8] cmd64x_init_one+0x60/0x74 [cmd64x]

The "..."s signify more lines which I didn't copy.  I couldn't get 
anything above the DAR: line, as the boot logo was in the way.  I tried 
to get everything I thought was the most relevant.

Is there a workaround?  Has anyone seen this before?  I've got a Rev 1 
motherboard, if that could be a part of the problem (that's not going to 
change, though).  I'd really rather be runnign a 2.6 kernel if possible.

2.4.27 from stable boots just fine.

Purdue University ITAP/RCAC       --- http://www.rcac.purdue.edu/
The Computer Refuge               --- http://computer-refuge.org

Reply to: