[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt (intentionally?) brain dead?

> > The following packages have unmet dependencies:
> >   gconf2: Depends: gconf2-common (= 2.10.1-6) but it is not going to be installed
> >           Conflicts: libgconf2-4 (< 2.10.1-3) but 2.10.1-1 is to be installed
> >   gnome-core: Depends: bug-buddy (>= 2.10.0) but 2.8.0-3 is to be installed
> > E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
> Try without --simulate, and you should see. And maybe try digging a
> little deeper before calling something 'brain dead'...

apt could try to be a bit smarter about reporting precisely how the
conflict (or uninstallable package way down in the dependency chain)

Among other things, that would make the job of buildd admins a lot easier

I concede the above example looks easy, but it's still hard to guess what
package needs to be updated (or even built) from that output alone.


Reply to: