[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 'gdm could not write to the auth file' -- ubuntuPPC_5.04

On Fri, 7 Oct 2005, Kim Cascone wrote:

I have two machines (both of which dual boot into Ubuntu 5.04 and OS X 10.3.9)
- an iBook G3 running Ubuntu 5.04 (all current updates) on a 4G partition
- an iMac DV G3 running Ubuntu 5.04 (all current updates) on a 5G part

I have a 10G external (pocket) firewire drive which I formatted on the iBook as an ext3 fs drive the drive shows up on my iBook after plugging it in (I guess hotplug handles the automount)
I backed up my iBook onto this drive using rsync as follows:
sudo rsync -av --progress / /media/ieee1394disc/foo1

rsync -avx would be better [ --one-file-system ] : you really don't want to try to back up /sys (which gave the errors) and /proc. Of course, then you have to separately back up any real filesystems mounted elsewhere (e.g. /home might be separate, although from what you wrote below, it isn't). You might also need to restore a skeletal /dev to boot from the backup, by using mknod to create /dev/console and /dev/null, or you might find that an initrd handles this for you.

A lot of these files (/tmp, some parts of /var) don't really want to be backed up.

but I saw my iBook's HD was on the backup drive -- although I am not sure how to verify the backup...

Long answer: learn to write shell scripts - list all the (real) files that you care about, perhaps using something starting with 'find / -xdev -type f ' then loop through these to compare them to the mounted copy using 'cmp'.

You also need to confirm the ownership of 'system' files (basically, everything except users' home directories) if you are going to restore from the rsync'd backup - people have been known to rsync as a user, changing the copied files' ownership to that user.

For a full system restore, you might find that backing up home directories and any files you have modified is more productive, at the cost of having to reinstall and update the system. Of course, that wouldn't help if you'd accidentally deleted a file and wanted to restore only that file.


I took the drive physically and plugged it into the iMac DV

it didn't show up on the iMac DV but I am able to cd to /media/ieee1394disc

That sounds like the mountpoint, which would be on the root filesystem. If the drive was mounted there, of course, you would have been ok.

so I assumed it automounted but for some reason didn't place an icon on the desktop...I have it set up that Computer, Home and Trash all show up on the desktop...

Heh, there's no accounting for our individual graphical preferences, is there ? The one thing I really liked about ubuntu when I tried it was the icon-free gnome desktop. 8)

I wanted to back up the iMac DV as well so I ran rsync on this machine

sudo rsync -av --progress / /media/ieee1394disc/foo2

it spews stuff to the terminal for a while and then ends with some error messages...they look a little different than the errors I got on the iBook

I'm not sure what happened but then I ran gparted and it scanned for volumes but found nothing...something seemed wrong so

I rebooted the machine

and I get the Gnome splash screen with the login window

I enter the correct username and pswd

and I get a small error window which states:

'GDM could not write to the authorization file...
You are either out of disc space or the home dir could not be opened for writing'

I removed the external firewire drive and reboot again...

the same error message appears...

so my questions are:
	- how do I solve this?
- did I inadvertently write to the same partition on the internal drive (and not the external firewire drive) therefor filling it to the max?

 Sounds like it.

	- or did the rsync backup clobber an auth file?
		- and if so how do I fix it?

I tried booting into 'live-expert-powerpc' mode from the Live CD
but I cannot cd to the drive for some reason

I'll have to leave it to somebody who has used ubuntu recently to point out what you need to do. From memory, it asks which filesystem you want to use (yes, I have multiple partitions) and I thought it said where it was mounted - or perhaps you have to mount it yourself.

I suspect that I either have to delete the backup to free up room on the drive -- wherever the backup is on the HD

Probably at /media/iee... (so, if the root filesystem is mounted at /mnt in the rescue process, that would be /mnt/media/iee... ).

or I have to repair permissions on the authorization file...

That sounds like a 'mac' solution. Permissions of ~/ don't normally change of their own accord on linux.

anyone offer some insight and help?

Once you've recovered enough to log in normally, make sure the external drive shows up in 'mount' before you try to write to it. Many of us have done this sort of thing in the past, but using a system with no direct root login probably makes recovery that little bit harder, which is where the Live CD will come in handy when you get the hang of it.

 das eine Mal als Tragödie, das andere Mal als Farce

Reply to: