[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Hello and sources.list


I'm new to Debian for PPC - tho I have run Ubuntu and
other Debian-based distros on knackered PC's. 

I recently brought a new hard drive for my G3 Pismo
500mhz Powerbook and decided to install Debian to see
if it would run. I'm sure I'll be posting lots here as
there's plenty I have to learn. 

After using the 1st Debian CD to install a base system
and post-installing x and gnome, the first question I
have is this: after just using the  I only have one
repository in my sources.list searching this
repository I can't find samba vlc or a host of other
basics that I use day to day. I have googled "debian
repositories ppc' and searched the Debian site I can't
seem to find anything...can anyone let me know any
other repositories I can use? 


--- Chadwick <gmrwick@gmail.com> wrote:

> On 9/25/05, Kim Cascone <kim@anechoicmedia.com>
> wrote:
> ....
> > - I read the info on yaboot and did the following:
> > - I reset NVRAM
> > - I booted into Open Firmware and tried to boot
> from the yaboot
> > manually but...
> > - still no luck
> What did you do at the OF prompt?  If you still have
> an untouched
> linux FS, then yaboot, yaboot.conf (in /etc), and
> your kernel should
> be all you need.
> Maybe you can do this again, write down exaclty what
> happens, and send
> it in a reply.
> > - so I loaded up the live disc of Ubuntu,
> installed the 'gparted'
> > package and looked at the iMac's drive (cause OS X
> disc utils UI sucks)
> > and I didn't want to read the unix man on disc
> utils at that point...
> > but 'gparted' let me see the entire drive and
> Linux (ext3) and New
> > World (HFS+) parts as well as the OS X HFS parts
> were all still
> > there...
> >
> maybe there is a 'rescue' option from the install
> disk?  I think the
> chroot idea mentioned previously could work.  Let us
> know if it did!
> > so I am pretty certain that the yaboot got
> hosed...
> > - I am assuming that when making a backup of the
> OS X (HFS) partition
> > you need to use something that doesn't try to take
> over the whole drive
> > -- and possibly clobber the yaboot.conf file in
> the process...any tips,
> > suggestions, URL's would be appreciated...
> >
> yaboot.conf is in /etc... which should still be
> there.  Perhaps OF
> doesn't go to the bootstrap partition anymore. 
> Somehow running ybin
> in the correct situation would help
> > so my questions are as follows:
> > - was it OS X Disk Utilities that clobbered the
> yaboot?
> If you ran nothing else that could have done this,
> then we can assume
> so.  That is good to know!
> > - and how does one fix this running a Live Linux
> distro...
> >         - side note: I tried booting using
> OpenFirmware and none of the parts
> > I entered seemed to work per the instructions on
> the penguinlinux.org
> > yaboot page
> this similar thing has happened to me.. the symlinks
> that yaboot.conf
> pointed to were off, so I tried booting from OF
> (can't remember if it
> worked, sorry).. But I recall reading a great deal
> about Open
> Firmware.  Its good reading!
> Please let us know what you do, especially what
> happens in OF, and if
> the chrooting the mounted partition works!
> --
> Chadwick

Yahoo! Messenger - NEW crystal clear PC to PC calling worldwide with voicemail http://uk.messenger.yahoo.com

Reply to: