[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sarge install on Orldworld was successfull, but minor quirks

On Fri, 26 Aug 2005, Christian Walther wrote:

On 25/08/05, Roopchansingh, Vinai <vroopcha@mail.mcw.edu> wrote:

I have not be able to get any console activity at all, either with fbset
or otherwise.  2.4 works fine, as does X.  But the boot text is "mildly"
troubling ;-)

Might just be some weird combo of Old World Macs, ATI cards and the G3
upgrades ...

Yepp, there is something strange with the platform. I regularly power
on my Mac and the screen remains black. The day before yesterday I
installed Sarge on this machine, booted into the installed system
using Quik without any bigger problems (except for missing boot
messages, and no messages from Quik at all). It's just an idea, but
maybe the path to the ATI card is to long for this old and buggy
I don't have these problems with other cards, for example a Matrox
Millenium II-Mac edition.

Strange...  I've tried with the the on-board video on my 8500 (the
"controlfb" device) with the same results as with the ATI card - i.e.
Tux logo, but no console messages.  I'll look into the "charset" though
- I haven't seen or heard of this before...

As I turned on my Mac yesterday evening the screen remained black, and
I had to do a Prom-Zap in order to make it work again. Oddly enough,
sometimes it's sufficent to do a CD ROM-boot to get a screen.

After my experience of the last couple of days, for me the best
practices seem to be to
- Create an OS 9 partition, install and configure BootX
- Install the system
- Boot into it
- Copy the kernel file to ":System folder:Linux Kernels"

This is what I've been doing for ages now. If your machine is supported,
even back to System 7.5 worked well enough with this path.

Alternately, after booting into Linux
- use nsetenv|grep device to check the configuration of input-device,
output-device, boot-device
- use dmesg|grep ^fb0 to determine the path of the graphics adaptor
(make sure that output-device is set to this path, I noticed that it
isn't in my configuration)
- write down all values.
- these can be used in conjunction with BootVars to boot into Linux again

I'll take a look at these.  It's been so long since I've tried any other
way to boot my 8500, I forgot about being able to access OF from within
linux with nsetenv ...  Definitely have to take a look again soon.

FYI: With an ATI card, specifying "No video driver" when booting the
Installer doesn't work. There isn't any output until the installer
finally starts up, and the additional consoles remain black. Disabling
the "No video driver" option in BootX, gives a standard console.

Doesn't work for me in either case, enabled or disabled...

Thanks for the info Christian.  I'll definitely have to look into the OF
tree and see what's lurking there...


Reply to: