[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: G3 iBook still hanging when coming out of sleep.

Ian Wienand wrote:

> On Sun, Jul 24, 2005 at 10:27:15PM +1000, Erik de Castro Lopo wrote:
> > How can I confirm that and how can I fix it.
> Well, as a start, if you apply the patches mentioned in
> http://lists.debian.org/debian-powerpc/2005/04/msg00069.html
> and make the extra fixes mentioned in 
> http://lists.debian.org/debian-powerpc/2005/04/msg00120.html
> against say 2.6.12-rc2, does it work then?
> At least that is a start that's not too far behind current kernels.

OK, I grabbed and tried to apply the patches in msg00069
above but it seems that they had already been applied. I tried to
check by hand but they were simply too messy and I didn't trust

I then grabbed as you suggested. Again, most of the patches
had already been applied. I pushed ahead anyway. When asked
I said 'n' to reverse the patches and 'y' to apply yhem anyway.
Out of the 30 odd hunks, 5 or 6 were applied successfully.
I then applied the assembler patches by hand. I thing I got it right,
but the code had changed quite a bit.

However, when I came to build the new kernel I get:

    arch/ppc/kernel/cpu_setup_6xx.S: Assembler messages:
    arch/ppc/kernel/cpu_setup_6xx.S:289: Error: symbol `__init_fpu_registers' 
            is already defined

I managed to clean that up by hand and the kernel is now compiling
but I really don't trust myself with what I've done.

Does anybody have a clean patch against or 3 that works
with one of the older G3 iBooks?

  Erik de Castro Lopo  nospam@mega-nerd.com (Yes it's valid)
C++ : an octopus made by nailing extra legs onto a dog.

Reply to: