[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

MacOnLinux and Network Configuration



Hello!

I'm a new user of Apple Hardware, and i'm trying to get MoL working properly.

It works pretty well, but till now i has not been able to get network working.

I tried both sheep and tap drivers (i prefer tap, but tried also sheep).
With sheep it simply does not work. there is little to configure for it, but does not work.
I cant simply send packet in/out to/from the guest OS.

With tap i did as follow:

i created tap device /dev/net/tap, change permission to rw rw rw, then interface  /dev/net/tap0 with tunctl (from root, to avoid
permission issues), tried either with 192.168.2.0 (as documentation suggest, but it seems a bit strange to me) or 2.1, 
then i launched (by root) mol  with tap0 -tap option. I configured MoL to use an address of 192.168.2.10 and netmask 255.255.255.0
for the new interface. but i cant send/receive packet too

anbd  i get, on console, a lot of messages like:

"enet2 write: Connection refused", when mol try to send packet outside. inside osX/mol i can in all configuration
(sheep/tap) ping myself 
i would prefer TAP driver since i can do bridging with it, but sheep would be ok too..



Then i have another question: a few weeks ago i tried to configure osX color management from MoL. And it worked!
I was able to see changes on the apple on screen when i moved slides up down on the wizard.
Now i'm not able any more. I cant configure color management any more... Is this a my fault? can i have changed something
that does not allow me to configure it? I installed Photoshop CS2 and C1 Pro 3.7, but they are stand alone soft i think..

Oh, i'm using osX Panther as Mac and debian ppc as Linux


Thank you in advance for any advice!
Paolo


PS: please Cc: me on replies, as I'm not subscribed to list!



Reply to: