[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Gnome vs. KDE with ALSA

Mike S wrote:

Mike S wrote:

This is an opinion question, I am wondering who on this list uses Gnome and who uses KDE, I like the simplistic look of gnome, which is why I switched to gnome, but however one thing that is really important to me is sound.

Googling it, I have found very little literature on that subject, and the only output I have been able to produce sound with is esd. ALSA and OSS sinks both give me 'unable to construct test pipe' and artsd runs the test with no audio, sound in mol is broken now, with a report of "OSS sound device unavailable (will be used anyway)
OSS sound driver"

So I do not know whether MOL cannot use OSS, and/or whether esd just takes total control of /dev/dsp, which I have read a little bit about.

This is making me want to switch back to KDE, but I must ask, is ALSA possible in gnome?

ok now I think I may have run into some type of bug. I was fiddling around with mol, and ran "killall esd" to kill the esd daemon, then somthing was wrong with mol, Sync Error, so it never started.

But here's the wierd thing, about half an hour later, after installing unrelated packages such as eterm, and playing mahjongg, I decided to test it again, I went into Multimedia Systems Selector, switched to OSS and ran a test. It worked!

Now here's the strange thing, I thought it might have something to do with killing the esd daemon, so I switched to ALSA, ran the test, and that failed. So I switched back to OSS, ran the test, and that failed.

Does anyone have any idea what's going on here?

--Mike S

I wrote too soon, I still have no damn idea what's going on, and it's kind of upsetting me. I reproduced the results. Here's what I did:
1. Closed Thunderbird after that last post
2. ran esdctl on
3. closed the Multimedia Systems Selector window that was open
4. open the Multimedia Systems Selector
5. tested esd, and failed
6. switched to oss tested, and it worked.

I switched to esd, tested and that failed, but then I switched back to OSS and it worked. Switching to ALSA and tested, that failed. Switched back to OSS, tested and that failed closed the window ran esdctl off and esdctl on reopened the MSS window and tested esd, that failed, and then switched to OSS tested, and it works again.

Does this sound like bug like activity? It very well may be I guess, I am running gnome 2.10.1, and this looks to me like it may be a bug with alsasink, or maybe just MSS switching to alsasink, but someone more knowledgeable please let me know.

--Mike S

Reply to: