[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

MOL-modules



Yes, I am not sure whether this list is the appropriate one for this, or some devel list, but I have always gotten awesome answers here, so I am going to "bite the bullet"

I attempted to compile the mol-modules two ways this afternoon. First from a Wiki page from ubuntu located: http://www.ubuntulinux.org/wiki/MacOnLinuxHowto

and then one comprised from several different web sites and posts and such that were debian specific. Both, when done right, yielded the same results, when I started mol I got the error that it could not load the module, that it was the wrong type or something. So I googled for a while, finding next to nothing, then I ran across some obscure post about an nVidia (or however it's spelled) kernel module needing a patch to compile under gcc 3.4.(1 maybe?), and remembered that I just upgraded to gcc 3.4 last week. So I removed gcc3.4 (and base) and manually linked the links in /usr/bin to the 3.3 counterparts (gcc, gcov, gccbug), went back into the /usr/src/modules/mol, did the "debian/rules build" and "debian/rules binary-mol-modules" installed the resulting deb, and viola mol worked!

So my QOTD is twofold, why are things so different in gcc 3.4, (if that can be answered simply) and based on what I have said, is there I patch I needed, or did I do something wrong?

I am on a self-compiled 2.6.12-rc6 kernel, (compiled with gcc-3.3.6 (Debian)) and when I installed gcc-3.4 (and base) I did manually relink /usr/bin/gcc,gcov,gccbug to the 3.4 counterparts (maybe my mistake?)

Thanks in advance for help/suggestions
--Mike S



Reply to: