[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Fwd: Re: Fwd: Re: multible partitions?

> >>  ieee1394: sbp2: Logged into SBP-2 device
> >>  ieee1394: sbp2: Node 0-00:1023: Max speed [S400] - Max payload [2048]
> >
> >What's missing here is crucial: there should be a SCSI device registered
> >here, usually sda. Not having anything SCSI related here is odd. What
> >happens in the kernel log when you try a mac-fdisk -l /dev/sda at this
> >stage?
> Unluckily I just have cfdisk, fdisk and sfdisk, but not the mac-fdisk.
> The first mentioned ones do not produce any output.

Install mac-fdisk (or parted) if you want to deal with Mac partitioned
disks (that's what your disk is, right?).

> >Did you unplug or power down the firewire disk in between?
> Yes, I tried "resetting" by unplugging,
> replugging and powering down several times.

That might've unregistered any firewire scsi device registered in the
first step. Repeat the whole procedure without powering down the firewire
disk, and send the log by PM please.

> >and found the first 'SCSI' device ever in the system. Which is odd,
> >because the firewire sbp2 driver ought to have located your firewire disk
> >before, making this one sdb.
> I checked USB stick and FW drive at the same
> time. When the stick is attached and mounted:
> fdisk -l /dev/sda shows the usb stick,
> fdisk -l /dev/sdb gives no output
> So the FW disk seems to be ignored completely.

Seems like it.

> >Might be interesting to see what usb-storage has to tell here -
> >deregistering the sda1 disk perhaps. Or maybe it got automatically mounted
> >and not hasn't been unmounted yet (check the output of 'mount' before
> >unplugging it).
> Yes - here I unplugged the USB stick.

What happens in the kernel log when the stick is unplugged? Are any
partitions from the stick still mounted?

> >What kernel version does this happen on? Any difference if you plug in the
> >firewire disk _after_ the kernel has booted up?
> The kernel is 2.4.27. I noticed no diffenence

Never tried firewire with a 2.4 kernel. I'd recommend switching to 2.6

> Another strange thing:
> I read cat /proc/partitions: with the FW disk and
> USB stick attached  - and then removed the USB
> stick. There was no change in output at cat
> /proc/partitions - exactly the same values, which
> IMHO are correct for the stick and not for the
> disk:

That is definitely not supposed to happen - unless the kernel still has
partitions mounted from the stick, or other I/O ops pending. Again, check
the 'mount' output. My (2.1.11) kernel removes the /proc/partition entries
for the USB stick upon unplugging. The entries still being present means
the kernel still has the stick registered, and subsequent I/O fails since
it actually was removed. Either the device removal notification does not
get through, or the kernel holds on to the device because there are still
channels open on it. The mount table and the kernel log should have some
clues there.


Reply to: