[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

B&W G3 Installed Kernel Hangs after loading ohci_hid



I've been trying to install sarge on a B&W G3 with a rev c logic board, adaptec scsi card, and an ide drive on which I'm installing testing. I've been at this off and on for a week or two, and I always get stuck at the same point. The installer works well enough, but for some reason none of the installed 2.6 kernels will finish booting. It loads SCSI, prints out a lot of output about pcilyx then it prints out the first two lines of ohci_hid's output, and then just hangs there says somthing about "64 blocks ". The installer kernel of the same release works fine. The USB keyboard works throughout the installation process. I have no idea what's going on, I can't look at any logs or anything.

I tried to install a 2.4.27 kernel, but it dies because it can't read my hard drive position (no such device (0,0)) so i'm assuming that's because the ide driver isn't built into the 2.4.27 image.

I've tried downloading a fresh kernel after booting the installer and chrooting into the install. I tried the appending nousb option, but the kernel came up in recovery mode on account of having to reset it after the crash, and without the usb modules the keyboard didn't work. I couldn't do anything to the machine so I just hard reset it again. So how can the installer

Kernel work so well and the same kernel installed on a hard drive work so badly? I've searched around the internet and I haven't seen anyone with the same problem. I've got



Reply to: