[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Switching from BootX to quik

On Tue, Feb 15, 2005 at 10:28:33AM -0500, Rich Johnson wrote:
> On Tuesday, February 15, 2005, at 03:02 AM, Hans Ekbrand wrote:
> >
> >I thought that I could always zap pram and boot from cd into macos and
> >bootX, but holding down command-option-p-r after reboot doesn't help.
> >The screen stays black and I don't hear any disk spinning up. Tried to
> >boot from CD or floppy, but failed. I realize that I need a mac-serial
> >cable and nullmodem-cable to debug this further.
> >
> That's odd.  Given that you've wiped MacOS from the disk you should get 
> a grey screen with the no-disk icon.  Not hearing the disk is odd as 
> well.
> Ignoring the disk for now, the symptom indicates that NVRAM wasn't 
> reset.  You need to hold cmd-opt-P-R down _during_ boot, not after, and 
> hold them down until you hear the second boot chime.
> Apple's Howto is at: http://docs.info.apple.com/article.html?artnum=2238
> If all else fails, you can open the case and remove the PRAM battery 
> until the setting evaporate.  (the battery may need replacing anyway.)

Thanks for motivating me further, I think didn't press cmd-opt-P-R
early enough in the boot process. Now the box is up again. Strangely
enough, it can boot from harddisk to MacOS. I expected that it would
only boot from CD. I still got MacOS, and it is on a partition with a
lower index number than the linux partition, so if ata:0,0 finds the
*first* bootable partition it couldn't work.

I changed to the boot-device and boot-file to

boot-device ata/ATA-disk@0:6
boot-file ata/ATA-disk@0:6/boot/vmlinux-2.6.8-powerpc

 and guess what happened, linux booted!!!
It didn't get its initrd and therefore failed to mount root,

VFS: Cannot open root device "<NULL>" or unkown-block(0,1)
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on uknown-block(0,1)

but that should be a minor problem.

The boot-file argument, should that point to the virtual image name
given in /etc/quik.conf or a real file containing the linux kernel? 

I saw in an earlier post of yours, that you hade the boot-file set to
"New", which presumably is a label, not a file name. So I tried 

boot-file Linux

with this /etc/quik.conf
but it didn't work :-(

The OF variables that I needed to change to get Linux booted by quik

nvsetenv load-base 0x100000
nvsetenv boot-device ata/ATA-disk@0:6
nvsetenv boot-file ata/ATA-disk@0:6/boot/vmlinux-2.6.8-powerpc

(but this boot-file setting gives no initrd and thus no root fs)

/boot is on the same partition as / (/dev/hda6)
no symlinks involved (well, there are symlinks in /, but they are not
mentioned in /etc/quick.conf).

Hints anyone?

note that I use Debian version 3.1
Linux emac140 2.6.9-1-686 #1 Thu Nov 25 03:48:29 EST 2004 i686 GNU/Linux

Hans Ekbrand (http://sociologi.cjb.net) <hans@sociologi.cjb.net>

Never trust a message that appears to come from me but is not signed
with GPG! It is most likely SPAM or a VIRUS sent by someone who has my
adress and got infected.

My public key, ID 7050614E, is available from the HKP key servers and
here: http://sociologi.cjb.net/~hans/key.txt

Attachment: signature.asc
Description: Digital signature

Reply to: