[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem netbooting a prep machine

On Monday 20 December 2004 13:56, Sven Luther wrote:
> On Fri, Dec 17, 2004 at 05:15:22PM +0100, Philippe Guyot wrote:
> > Hi all!
> >
> > I am trying to install a Debian on a powerpc 604 machine from Bull
> This is probably a prep box, do you know if it uses the prep or ppcbug boot
> mechanism ?
> > It has firmware 03.03.09 copyright Firmworks.
> >
> > If it doesn't lie, it is a prep machine.
> Cool.
> > I made all the stuff for netbooting (dhcd,tftp and so on).Seems OK.
> >
> > I am loading vmlinuz-prep.initrd ("load net") and the firmware answer:
> >
> > ### : 0 d e  boot-file = vmlinuz-prep.initrd
> Is this the rc2 or daily build, 2.4 or 2.6 d-i kernel ?


> > I examined the memory, the image seems well loaded at load-base
> > (comparing hex display of memory at load-base and at load-base+size of
> > vm...with the output of hexdump vm....
> > (only first and last blocs of memory, of course)
> >
> > then I typed "go" to start execution. firmware answer : ### : 0 d f
> > and the machine is frozen.
> >
> > (of course, "boot net" gives the same result).
> >
> >
> > Can somebody point me to a right direction ?
> Not much, but i suppose that it may be that you run into some kernel size
> limit. Where does load-base point to ?

load-base = 0x 400000

I made some experiences, not always pure orthodoxy:

First of all, when booting disk ("boot disk"), the OF displays 0 d f then 
boots proceed, so I think this 0df is not an error message.

As far as I can see by dumping memory from place to place, the vmlinuz loaded 
does not overwrite parts of code from OF (which should be at 0x 100000). 
There were only zeroes before loading.

So I tried to load...yaboot.  (yes, I know, not the right way for a prep 
machine but...)

It gave strange things: It runs but you can enter only 2 chars at the prompt. 
I realize also (tcpdump) that when loaded and running, it request "yaboot" to 
the ftp server and not "yaboot.conf".  I went around this by loading first 
yaboot, then moving a yaboot..conf on yaboot then "go" . Same result however 
(may be because this is *not* a chrp machine) but the fact is that yaboot is 
loaded and running.  May be some clue arising from that? I red from IEEE 
standards that .ELF must be annotated for running on IBM machines (but saying 
the truth, I do not understand yet what doest that mean...).

A last thing: I hardcoded the client's mac address in the server's arp cache 
to prevent interruption of tftp by an arp request.


> Friendly,
> Sven Luther

Reply to: