[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: TEST: Sleep patch #7

Benjamin Herrenschmidt wrote:

On Mon, 2004-12-06 at 20:04 -0200, Federico Gamio wrote:
On Sun, 2004-12-05 at 21:34 +1100, Benjamin Herrenschmidt wrote:
(As usual, I'm cross posting several lists, please don't reply to all of them,
and CC me as I'm not subscribed to all of them neither)

Ok, here's the 7th version of the sleep patch for ATI based albooks &
iBook G4. Other machine users, please test too as it may cause
regressions (or improvements) as well.

My 15" PowerBook (1.25Ghz, ATI 9600, PowerBook5.2) has the same problem
with suspend to ram patch.
I can suspend closing the lid or pushing the power button (I use
pbbuttonsd) and all works perfect.
I can repeat this for several times, but in some cases they don't want
to go sleep and the LCD remains active.
If I try to shutdown with init 0, then X become corrupt and the system
freeze, so I believe that there is a bug in radeon suspend/resume.
I can't reproduce the bug, it shows when he want :(

can you try in console mode without X using "snooze -f" repeately, does
it ever happen ?


The problem triggers when you keep in sleep mode for 6 hours (I wlll try shorter periods).
With "snooze -f" and console makes no difference.
Right now I have my PB displaying (sorry if I make some mistake, but I will copy all debug information by hand):

HID1, before: 80002c80
radeonfb (0000:00:10.0): resuming from state: 0 . . .
PCI: Enabling device 0000:00:10.0 (0000 -> 0003)
H1D1, after: 80002c80
cpufreq: resume failed to assert current frequency is what timing core things it is
Apple USB OHCI 0001:10:18.0 disabled by firmware
Apple USB OHCI 0001:10:19.0 disabled by firmware
eth0 resuming
PHY ID: 1410cc1, addr 0
hda: Enabling Ultra DMA 5
hdc: MDMA, cycleTime: 120, accessTime: 90, recTime: 30
hdc: Enabling MultiWord DMA 2
usb 1-1: usbfs: USBDEVFS_CONTROL failed cmd hid2hci rqt 64 rq 0 len 0 ret -110
usb 1-1: USB disconect, address 2
drivers/usb/input/hid-core.c: can't resubmit intr, 0001:10:1a.0-1/input1, status -19 ehci_hcd 0001:10:1b.2 Unlink after no-IRQ? Different ACPI or APIC settings may help ohci_hcd 0001:10:1b.1 Unlink after no-IRQ? Different ACPI or APIC settings may help ohci_hcd 0001:10:1b.0 Unlink after no-IRQ? Different ACPI or APIC settings may help
usb 1-1: new full speed USB device using address 3
Could not suspend device 1-1: error = -108
hub 1-0:1.0:  hub_port_status failed (err = -108)
hub 1-0:1.0: cannot disable port 1 (err = -108)
hub 1-0:1.0: hub_port_status failed (err = -108)
hub 1-0:1.0: reactivate --> -108
Bluetooth: HCI USB driver ver 2.7
hci_usb_probe: Can't set isoc interface setting
Oops: kernel access of bad area, sig: 11 [#1]
NIP: E26BFA88 LR: E26C0E78 SP: D79EDD40 REGS: d79edc90 TRAP: 0300 Not tainted
MSR: 00009032 EE: 1 PR: 0 FP: 0 ME: 1 IR/DR: 11
DAR: 0000011C, DSISR: 40000000
TASK = d7d98c90[10660] 'modprobe' THREAD: d79ec000Last syscall: 128
GPR00: 00000014 D79EDD40 D7D98C90 00000000 DE44DC00 00000083 00000000 C0450000 GPR08: C0A94A0C 00000004 00000000 D79EC000 82992424 1001E284 100013A4 00000000 GPR16: 00000000 00000000 00000000 00000000 100013A4 10018B30 10018BA0 DFFF7BF4 GPR24: 00000002 C0A94A00 C0A9B1E0 DFFF7BE0 DFFEF2C0 E26C18B4 00000000 00000000 Call trace: [e26c0e78] [e2528124] [c0253598] [e2528434] [e26c0d88] [e252807c] [c0253354] [c02534d4] [c0253aa4] [c02540a8] [e2528184] [e26b7030] [c003a004] [c0006060]
eth0: Link is up at 100 Mbps, full-duplex
eth0: Pause is disabled
eth0: no IPv6 routers present

I have no USB device attached to my PB, and the suspend cycles do not restore the console to previus state, it stays displaying the debug information.
I tried to log in by network and no sshd present.
I tried to change console, and nothing happens.
If you need more data, please tell me.

Also make sure you have APM emulation built into the
kernel and that /dev/apm_bios exists.

Yes and yes.
I have apm emulation and /dev/apm_bios exists

Thanks for all your work.


Reply to: