[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: KDE Blues

On (16/11/04 12:11), facemann wrote:
> Hi all, 
> I hope this is the correct list for this.  If not,
> please advise.
> I have just loaded woody 2.4.18-newpmac on an older
> G4.  Runs great from the command line.  When I run
> 'startx' the KDE splash screen comes
> on, I have a mouse, then it fails back to the command
> line.
> The only EE line from XFree86.0.log is:
> (EE) R128(0): [dri] DRIScreenInit failed.  Disabling
> DRI.
> The tail end of XFree86.0.log is:
> (II) Initializing built-in extension XKEYBOARD
> (II) Initializing built-in extension LBX
> (II) Initializing built-in extension XC-APPGROUP
> (II) Initializing built-in extension SECURITY
> (II) Initializing built-in extension XINERAMA
> (II) Initializing built-in extension XFree86-Bigfont
> (II) Initializing built-in extension RENDER
> PEXExtensionInit: Couldn't open default PEX font file 
> Roman_M
> (II) Keyboard "Generic Keyboard" handled by legacy
> driver
> (**) Option "Protocol" "ImPS/2"
> (**) Configured Mouse: Protocol: "ImPS/2"
> (**) Option "CorePointer"
> (**) Configured Mouse: Core Pointer
> (**) Option "Device" "/dev/input/mice"
> (==) Configured Mouse: Buttons: 3
> (**) Option "Emulate3Buttons" "true"
> (**) Configured Mouse: Emulate3Buttons,
> Emulate3Timeout: 50
> (**) Option "ZAxisMapping" "4 5"
> (**) Configured Mouse: ZAxisMapping: buttons 4 and 5
> (II) XINPUT: Adding extended input device "Configured
> Mouse" (type: MOUSE)
> Fatal server error:
> Caught signal 11.  Server aborting
> By the way, the G4 has an ATI Rage 128 and is
> connected to the monitor and mouse via a KVM switch
> into a USB port.
Hi Andy

I run debian (sid) on a 450MHz dual processor AGP GRaphics G4; I started
with woody and managed to get a reasonable KDE working environment with
benh kernels but never managed to get everything working.  After about
nine months I switched to sid and more recently I ugraded to the stock
debian 2.6.8 smp kernel.

I don't know how much you investigated debian prior to your install but
I would encourage you to either:

do a fresh install using the new sarge (testing soon to become stable)


It is considerably quicker and easier than the woody installer; it
provides the added advantage of discovering much of your hardware which
makes issues like getting the x-window system working painless.


upgrade your woody installation to sarge by editing your
/etc/apt/sources.list substituting all references to "stable" or "woody"
with "sarge".  Then if you have aptitude installed do:

aptitude update
aptitude upgrade

if not use apt-get (look the man page) but I believe you do:

apt-get update
apt-get upgrade
apt-get distupgrade

After upgrading you may still have to resolve your xserver problem but
you should achive better functionality generally.

However, to answer your question you need:

dpkg-reconfigure xserver-xfree86

And check the relevant settings - it is somewhat trial and error.

Alternatively, I can send you my XF86Config-4 file off-list which may
solve your problem.



www.clivemenzies.co.uk ...
...strategies for business

Reply to: