[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cannot boot via yaboot

Hash: SHA1

Barry Hawkins wrote:
| List,
|     Hello.  I have a problem booting my system that's similar to issue
| that others have had.  So far the workarounds that I have found in
| searching the list archives haven't gotten me out of this jam yet.
|     The machine is a Titanium PowerBook G4 500MHz; the install was sarge
| upgraded to sid.  The 2.6.8-powerpc kernel was installed via the Debian
| Installer.
|     Apparently when I installed mol, the kernel-image-2.4.25-power3 and
| its associates were installed, and horrible things happened to my yaboot
| configuration.  I was able to boot with my Debian Intaller disc and
| mount the filesystem.  I then entered a shell and inventoried the
| contents of /boot:
| (The permissions, owner, etc. are left off of the transcription)
| /target/boot # ls -la
| System.map-2.4.25-power3
| System.map-2.6.8-powerpc
| config-2.4.25-power3
| config-2.6.8-powerpc
| first.b
| initrd.img-2.6.8-powerpc
| initrd.old -> initrd.img-2.6.8-powerpc
| patches-2.4.25-power3
| second.b
| vmlinux -> vmlinux-2.4.25-power3
| vmlinux-2.4.25-power3
| vmlinux-2.6.8-powerpc
| vmlinux.coff-2.4.25-power3
| vmlinux.old -> vmlinux-2.6.8-powerpc
| The contents of /etc/yaboot.conf were:
| (Header omitted)
| boot=/dev/hda9
| device=/pci@f2000000/mac-io@17/ata-4@1f000/disk@0:
| partition=11
| root=/dev/hda11
| timeout=100
| install=/usr/lib/yaboot/yaboot
| magicboot=/usr/lib/yaboot/ofboot
| enablecdboot
| macosx=/dev/hda12
| image=/boot/vmlinux
|         label=Linux
|         read-only
|         initrd=/boot/initrd.img
| image=/boot/vmlinux.old
|         label=old
|         read-only
|         initrd=/boot/initrd.img.old
| When either of the labels is selected, the following message appears
| (The initrd.img in the message below is the one for 'old') and yaboot
| seems to perform the ofboot function:
| Welcome to yaboot version 1.3.13
| Enter "help" to get some basic usage information
| boot:
|   Linux                      old
| boot: old
| Please wait, loading kernel...
|    Elf32 kernel loaded...
| Loading ramdisk...
| /pci@f2000000/mac-io@17/ata-4@1f000/disk@0:11,/boot/initrd.img.old: No
| such file or directory
| ramdisk oad failed!
| Apple PowerBook3,2 4.1.8f5 BootROM built on 03/21/01 at 11:49:53
| Copyright 1994-2001 Apple Computer, Inc.
| All Right Reserved.
| ...
|   I find that odd, because when I manually specify the same (at least I
| think so) parameters from the boot: prompt, I can load the kernel up to
| where it panics.  (I had just finished migrating my email over to
| Thunderbird on Linux from Mail on Mac OS X before this happened
| <sigh>.)  The kernel panic probably looks familiar to some:
| ...
| VFS: Cannot open root device "hda11" or unknown-block(0,0)
| Please append a correct "root=" boot option
| Kernel panic: VFS: Unable to mount root fs on unknown block(0,0)
| So far I have tried the following lines at the "boot:" prompt:
| hd:11,/boot/vmlinux-2.6.8-powerpc root=/dev/hda11
| initrd=initrd.img-2.6.8-powerpc
| hd:11,/boot/vmlinux-2.6.8-powerpc ro root=/dev/hda11
| initrd=initrd.img-2.6.8-powerpc
| hd:11,/boot/vmlinux-2.6.8-powerpc ro root=/dev/hda11
| initrd=initrd.img-2.6.8-powerpc map=System.map-2.6.8-powerpc
| hd:11,/boot/vmlinux-2.6.8-powerpc root=/dev/hda11
| initrd=/boot/initrd.img-2.6.8-powerpc
| hd:11,/boot/vmlinux-2.6.8-powerpc root=/dev/hda11 read-only
| initrd=/boot/initrd.img-2.6.8-powerpc
| /boot/vmlinux-2.6.8-powerpc
| /boot/vmlinux-2.6.8-powerpc initrd=/boot/initrd.img-2.6.8-powerpc
| /boot/vmlinux-2.6.8-powerpc root=/dev/hda11 read-only
| initrd=/boot/initrd.img-2.6.8-powerpc
| hd:11,/boot/vmlinux-2.6.8-powerpc root=/dev/hda11 ro
| hd:11,/boot/vmlinux-2.6.8-powerpc root=/dev/hda11 ro
| initrd=/boot/initrd.img-2.6.8-powerpc
| If I am unable to boot using the old kernels, I am contemplating how
| else I might recover from this.  So far I have:
| 1.) Reinstall sid via the Debian Installer and hope for the best
| 2.) Install sid onto a free area and manually migrate the data
| 3.) Start from scratch 8^(
| Those are in order of preference right now.  Any insight, suggestions,
| wisdom, etc. would be most appreciated.
I ended up installing Debian onto a spare partition, and to my amazement
the Debian Installer had set up a yaboot entry for my original Linux
install!  There were 3, actually, and they all had the same label.  I
removed the two for vmlinux and ran ybin -v.  I tried rebooting and
choosing the label that referred to my main install, and it booted just
fine.  I can't say that I understand what happened, but I'll take it for
~ now.


- --
Barry Hawkins
site: www.alltc.com
weblog: www.yepthatsme.com
Version: GnuPG v1.2.5 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org


Reply to: